US Modality on Web Viewer

Hi. Retrieving an image in US mode, I can not see it correctly through the web viewer. I understand that the images in the US mode are encoded in another way. Is there any way of being able to view them in the web viewer correctly?

Thank you.

Daniel Gopp

US should appear correctly, haven’t had an issue. Do you have an error you can provide, or configuration?

Traducir el mensaje al español

Hi. Thanks for your answer. I attach how i see it, and my configuration. There is no error on the log. Im using windows. If is possible, can you tell me how i can start the service with debug level log? Thanks (and sorry my english).

Daniel

dicomweb.json (663 Bytes)

orthanc.json (14.2 KB)

2018-07-03.jpg

You may use the --verbose or --trace command options.

  http://book.orthanc-server.com/faq/log.html

Thanks for you answer. I have tried with --verbose, and I find this error:

E0704 08:04:27.745271 PluginsManager.cpp:164] Cannot decode image using GDCM: GDCM cannot change the photometric interpretation

I attach the complete log.

Thaks,

Daniel

log.txt (11 KB)

Could you provide the DICOM file (possibly anonymized) so we can reproduce the issue ?

Ye of course. Here is.

Thanks for your attention…

Daniel

a5a8bbab-854d5df4-e6a53025-38efe2e6-2f9db339.zip (4.89 MB)

Hi. Have you been able to reproduce the problem?

Thanks,

Daniel

Hi Daniel,

Sorry for the silence. I’ve just tried and indeed I can reproduce it. This is the first time we’ve images of this kind (TransferSyntax is RLELossless and PhotometricInterpretation is YBR_FULL).

I’ve filed the issue in our issue tracker but I have no idea when I’ll be able to work on it. On your side, any chance you can re-configure the modality to produce other types of images ?

Hi Alain. Thanks for your answer.

Can you tell me what the transfersyntax would be and the photometricinterpretation with which you know it should not have a problem? The equipment is a Mindray with color Doppler and I have not found where to modify these parameters, but if you give me that information I can consult the provider more accurately.
Thank you very much!!

Daniel

Dear Daniel,

I have tested your image using the Orthanc basic Web viewer, and it works properly on your image (see attachment).

Until the Osimis Web viewer is fixed, you are thus kindly invited to use the Orthanc basic Web viewer:
https://www.orthanc-server.com/static.php?page=web-viewer

Kind Regards,
Sébastien-

mindray.jpg

Hi Sebastien. Thanks for your answer.

I have tried previously with the Orthanc Viewer, but the same fault occurs to me. I have checked the version, and it is 2.3 for 64 bits in Windows.
According to the page, there is a version 2.4, but they are not compiled for 64 bits.

Would you be so kind as to send me or tell me where to get the compiled version for 64 bits in Windows?

Thank you so much!!

Daniel

Hello,

Orthanc Web viewer 2.4 for Windows 64 is part of the “OrthancInstaller-Win64-18.5.2.exe” installer:
https://www.orthanc-server.com/download-windows.php

Sébastien-

Hi.

I’ve fixed it in the OsimisWebViewer. It will be part of an alpha release that we’re planning to release later this week.

Hi,

the alpha release is now available:

Hi Alain.

Thank you very much for the solution. I’ve tried it on windows 64 bits, and everything seems to work fine.
Again, thank you very much for everything!

Daniel