remote access from my orthanc page

Hello
Please, I managed to have remote access using a freelancer, but when I enter the orthanc page, it asks me for a username and password.
in the configuration I find the default name is alice and the password is alicepassword, I tried to enter them without results, are these the correct identifications to be able to access my page remotely? or should I change them / if yes how? please

Hi Hammand

In order for the web search to run in the latest versions of Orthanc, you must modify 2 parameters within the orthanc.json file.

The first is to change the variable “AuthenticationEnabled” to true. The second is to activate the value of the variable “RegisteredUsers” by removing the “//” that appear at the beginning of the line // “alice”: “alicePassword” (you can replace alice and alicePassword with a user and a password of your choice.

You should have something like this, for example:

// Whether or not the password protection is enabled

“AuthenticationEnabled”: true,

// The list of the registered users. Because Orthanc uses HTTP
// Basic Authentication, the passwords are stored as plain text.

“RegisteredUsers”: {“admin”: “adminPassword”},

Good luck

William

Hello
thank you for your response, possibly I had already changed the parameters mentioned “RemoteAccessAllowed” and “AuthenticationEnabled” to true, but without results since yesterday

I did not know that it is necessary to remove the symbol \, when I do it I no longer have the right to enter even the localhost, and it asks me for a password, but when I have used them, it always refuses to enter , I changed the word alice by admin, nothing the same, it asks me for identifiers and refuses to return, the problem has even spread to the local station

how to do ? Please

It’s rather difficult to understand what’s going wrong so, could you please share with us your configuration file (at least the parts related to access: RemoteAccessAllowed, AuthenticationEnabled and RegisteredUsers) and your Orthanc output log?

Hi ,

yes with pleasure, I share my configuration page in attachments and here is a photo of page displayed

Sans titre.png

orthanc.json (21.8 KB)

OK. So, indeed, with such a setup, you should be able to access Orthanc from anywhere, without having to enter your password.

(You are most certainly aware of the danger of such a configuration if Orthanc is reachable from the Internet.)

May I please ask about the technical solution you are using for remote access ?

I had once the same issue when using Nginx to access Orthanc : i had disabled the password (and, by mistake, had broken Orthanc reachability) and Nginx kept on asking me for credentials.

Anyway, this does sound like an issue in the remote access system, not in Orthanc.

I would rather bet on the fact that Orthanc does not use your modified configuration file, but another one (maybe the default one)

As always, should should first have a look at your log files in “–verbose”, and carefully check the configuration file that is read by Orthanc:
https://book.orthanc-server.com/users/support.html

but there is no solution, since my configuration was right? , I use chrome and I modified the firewall

Je poursuis en français . Pouvez-vous vérifier, dans le log de sortie d’Orthanc, que le chemin du fichier de configuration est bien celui que vous attendez ?

La deuxième ligne du log ressemble à :

W0410 08:41:14.853893 OrthancConfiguration.cpp:61] Reading the configuration from: “C:\osi\bgo-osi-bin\data\CustomOrthancs\MainOrthanc\Configuration_MainOrthanc.json”

Car avec le fichier tel que vous l’avez envoyé, vous ne devriez jamais avoir à entrer un mot de passe.

Est-ce que le mot de passe est demandé uniquement lorsque vous accédez à distance à Orthanc, ou également lorsque vous ouvrez le navigateur sur la machine où tourne Orthanc ?

oui au debut , il m’a demandee pour les deux , apres c’est reussis a rentrer meme dans mes smartphones , mais apres quelques instances de navigations sa bloque sur les smart phhones et me dit acces bloque pourtant je n’'ai rien change m, je me suis dit peut etre le retour est instabble puisque j’ai change connexion de wifi vers mobile 4G , une fois je reviens a wifi le blocage persuste , je cherche un moyen sur pour se connecter sans interruption

Je suis désolé mais votre problème semble réellement être au niveau du mécanisme vous permettant d’accéder à Orthanc, pas à Orthanc lui-même. Aucune incohérence dans le traitement du réglage RemoteAccessAllowed n’a jamais été constatée.

Je vous conseille d’entrer en contact avec la personne ayant mis en place ce mécanisme d’accès. Éventuellement, vous pouvez partager ces informations ici (nom et configuration de l’outil utilisé… nginx ?) et peut-être qu’un membre de la communauté pourra vous aider.

En l’état, c’est tout ce que je peux vous dire.

salut , merci pour ta reponse

stp , une question , pour se connecter a distance par deux routeurs differents , ils doivent traveiller sur la meme adresse IP fixe et stable ou non ?

Je suis désolé mais je ne comprends pas bien cette question… Pour se connecter alternativement par deux routeurs ? Ou bien deux routeurs mis en cascade (??)

Quoi qu’il en soit, sur un même réseau, on ne peut pas, à ma connaissance, avoir des adresses identiques pour deux périphériques (== adresse MAC) différents.

Je réitère ma suggestion de faire appel au professionnel qui a mis en place votre solution d’accès. Nous n’irons pas très loin à l’aveugle dans les discussions sans avoir des informations techniques.

Bonne chance

pas grave mon ami

dommage que les constructeurs ne sont pas receptifs , ils doivent savoir que c’est pas tout le monde informaticien , c’est complique pour des professionnels de la sante , mais bon on a essayee et sa n’a pas marche

bonne chance a vous