Radiant(client) and orthanc(server another machine)


First of all I would like to say that your software is spectacular, my only problem is to connect the radiant with it because we were unable to use 3d in the web viewer. I made all the settings in the manual and deactivated the firewall, the echo does not reach the client and the client is unable to download the dicom file just to be able to search for the patient.

Hi Mauricio

The Radiant + Orthanc configuration works perfectly, it’s what I use every day in a large group of equipment.

All you have to do in Radiant is configure the Orthanc server parameters (AET, IP address and access port).

The only thing to do in Orthanc is to configure in the file orthanc.jsom, in the “DicomModalities” variable, the data of the equipment that Radiant has installed (AET, IP address and access port).

A good advice is to work all the computers with fixed IP.

In my case, modification in the file orthanc.jsom

// The list of the known DICOM modalities

“DicomModalities” : {


  • Uncommenting the following line would enable Orthanc to

  • connect to an instance of the “storescp” open-source DICOM

  • store (shipped in the DCMTK distribution), as started by the

  • command line “storescp 2000”. The first parameter is the

  • AET of the remote modality (cannot be longer than 16

  • characters), the second one is the remote network address,

  • and the third one is the TCP port number corresponding

  • to the DICOM protocol on the remote modality (usually 104).


// “sample” : [ “STORESCP”, “”, 2000 ]

“RADIANT4” : [ “RADIANT4”, “”, 11112 ],

“RADIANT9” : [ “RADIANT9”, “”, 11112 ],

“RADIANT10” : [ “RADIANT10”, “”, 11112 ],

“RADIANT11” : [ “RADIANT11”, “”, 11112 ],

“RADIANT12” : [ “RADIANT12”, “”, 11112 ],

“RADIANT13” : [ “RADIANT13”, “”, 11112 ],

“RADIANT14” : [ “RADIANT14”, “”, 11112 ],

“RADIANT15” : [ “RADIANT15”, “”, 11112 ],

“RADIANT21” : [ “RADIANT21”, “”, 11112 ],

“RADIANT23” : [ “RADIANT23”, “”, 11112 ],

“RADIANT50” : [ “RADIANT50”, “”, 11112 ],

“RADIANT241” : [ “RADIANT241”, “”, 11112 ],

“RADIANT247” : [ “RADIANT247”, “”, 11112 ],

“RADIANTTCO” : [ “RADIANTTCO”, “”, 11112 ],

“TOMOGRAFO” : [ “BAY85CT”, “”, 4242 ],

“ESTACIONTOMOGRAFO” : [ “PR_AW47”, “”, 4006 ]

Greetings and good luck


Thank you very much for the answer, I made all these recommendations, I was only able to look at the list of patients through the radiant, after configuring the .json file from orthanc, I believe that the download problem is something of a network, but I have already disabled even the firewall and it has not solved it.
The stranger who gets to show the download speed on the radiant and then stops.

The problem was the port targeting for the pc that had the radiant installed, thanks for the help.
Now is working good.
Do you know any RIS integrated with orthanc?

how did u solve the issue?

Hello Rana,

1)I did almost the same things as this video, the only differences were not having installed orthanc on the same machine so I used the external ip of each machine (orthanc server and Radiant client). https://www.youtube.com/watch?v=bsW4gYO4xrY
2)The machine with Radiant depended on a modem to provide internet, I had to configure the modem’s firewall in the Viral Servers menu informing the IP of the machine with Radiant and also the port informed in the server’s configuration file.

*Remembering that a fixed ip must be configured on both servers, but I ended up using DNS with a free ddns service, so any network that the Radiant machine will still have access to pacs orthanc.

correcting: "I had to configure the modem’s firewall in the Virtual Servers "