problems upgrading to 1.2.0 on Ubuntu

This morning I tried to update to 1.2.0 on Ubuntu 16.10 and failed.

First I tried the equivalent of
sudo /usr/sbin/Orthanc /etc/orthanc/ --upgrade

and that did nothing. I shut down orthanc.
Then I tried to add
deb stretch main
to my repositories and got a message saying the package wasn't signed and thus could not be read. I removed it.

Then I downloaded orthanc_1.2.0+dfsg-1_amd64.deb. That brought up a GUI which allowed me to install, but it kept coming back with 1.1.0.
I went to synaptic, found Orthanc, and did a complete removal. Then I tried again with what I downloaded. Initially it showed 1.2.0 in the details of what it was about to load. The install button did nothing the first time around and came back to 1.1.0 on the details the second time around.
I could use the Remove button to remove 1.1.0 and try again with 1.2.0 but it would never install it - only 1.1.0.

I searched my disk for orthanc. I found orthanc_1.2.0+dfsg-1_amd64.deb in /var/cache/apt/archives and it is part of the Ubuntu repository. Apparently I can't get around what Ubuntu wants to install (1.1.0) in order to install 1.2.0. Perhaps if the package were signed, it might work.

It isn't urgent to install the latest version, but it would be convenient to be able to work with the latest version, and see what else it has to offer.



Orthanc 1.2.0 is not available on Ubuntu 16.10 yet, but only on forthcoming Ubuntu 17.04:

You cannot assume that the “.deb” packages for Debian will also work on Ubuntu as such: You’ll have to wait for the “testing” package in Debian to be integrated into Ubuntu 16.10. Furthermore, there was no change in the database schema between Orthanc 1.1.0 and 1.2.0, so it is entirely normal that the “–upgrade” operation has no effect:

If you wish to try Orthanc 1.2.0 on Ubuntu 16.10 right now, you’ll have to compile it from source or use Docker:


Thanks for the reply Sebastien.
At this stage I don't see any real reason to make the effort to compile things.
Unless something changes, I think I will just wait for the Ubuntu release.


Don’t hesitate to try Docker in the meantime, it’s really a child’s play to make it work under Ubuntu: