Preventing ingest transcoding for particular modality

I have set the following option in my orthanc config file:

“IngestTranscoding” : “1.2.840.10008.”

In the Orthanc documentation it says that on a per modality basis transcoding can be disabled using the "AllowTranscoding " option.

Does this mean that instances from all modalities that have "AllowTranscoding "set to false will be stored in the syntax in which they are received by Orthanc while those modalities that don’t have "AllowTranscoding "set to false will have their instances transcoded to JPEG 2000 Lossless ( 1.2.840.10008. ) before being stored in Orthanc?

“AllowTranscoding” has nothing to do with “IngestTranscoding”.

“AllowTranscoding” specifies, for one remote modality, whether Orthanc C-GET SCP allows transcoding if contacted by the C-GET SCU of this modality, or whether Orthanc C-STORE SCU allows transcoding if sending DICOM instances to the C-STORE SCP of this modality.

Documentation of the configuration has been updated with this explanation:

I don’t fully understand the description of “AllowTranscoding”.
Does it mean Orthanc won’t transcode if it is set to false?
What happens if Orthanc has IngestTranscoding to JPEG, but the modality doesn’t support JPEG?

We also had a bug, kinda related to this setting.
We had a modality which said it support JPEG2000, but once sent, we noticed it wasn’t fully supported and the rendering was bugged.
We had no way to disable compressed transcoding for this specific modality, so we disabled transcoding globally.