Orthanc requesting username and password

(Sending again, as I accidentally sent my original reply to Jye only)

Jye -

Before being able to sign in, you'll need to create a user for yourself by
modifying this section of your Orthanc config:

"RegisteredUsers" : {
    // "alice" : "alicePassword"


As a complement to Erik’s answer, given your URL, you are visibly accessing Orthanc from a remote compute.

Because of this, you will have to set the option “RemoteAccessAllowed” to “true” in the configuration file. For security reasons, Orthanc blocks by default all the requests coming from outside the localhost.



Thanks guys. After a bit more digging I found all of the info. The json file was also very easy to configure.


where can I find the configuration file under windows? or generate it under windows?

This is described on the Wiki:

Do you experience problems with the explanations of this page?

I understand the wiki, but I cannot find the config file under Windows. I only see the executable. Starting the exe with the CMD prompt with the --config=Configuration.json doesn't work. I tried to make one myself with notepad++, doesn't work either... Is this only possible under Linux?


Here is a screenshot of what you should do to generate the configuration file:

Could you try and reproduce these manipulations, then post a screenshot if it fails?


Thank you so much for your patience. I forgot the phrase config=.
fast reading I guess..
So it is working now, thanks!

Fine! Enjoy :slight_smile:

hi ,
any one can help me to config orthanc http server.
when i enable the remote login, it is ask the user name and password for the login.
i put alice and alicepassword but it is not working

The default password is alicePassword (capital P) make sure you are entering the correct one.


The default username is “orthanc” (without the quotes) and the default password is also “orthanc”.

If you can’t access Orthanc from another computer, make sure that the “RemoteAccessAllowed” configuration option is set to “true” and that firewalls are properly configured:

Finally, learn about security:



Ok thanks. I will try and inform

Any one can share or orthanc configurations with users

“RemoteAccessAllowed”: true,

“AuthenticationEnabled”: true,
“RegisteredUsers”: {
“demo”: “demo-pwd”

hi bro
please check my configuration file i can not loging in to the orthanc using user name and password

orthanc.json (24.4 KB)

You should check your startup logs (https://book.orthanc-server.com/faq/log.html).
In your case, there are no RegisteredUsers while RemoteAccessEnabled is true → there’s a default orthanc:orthanc user that is created.

Please check this

// Whether remote hosts can connect to the HTTP server
“RemoteAccessAllowed” : true,
// “AuthenticationEnabled” : true,

// Whether or not SSL is enabled
“SslEnabled” : false,

// Path to the SSL certificate in the PEM format (meaningful only if
// SSL is enabled)
“SslCertificate” : “certificate.pem”,

// Whether or not the password protection is enabled (using HTTP
// basic access authentication). Starting with Orthanc 1.5.8, if
// “AuthenticationEnabled” is not explicitly set, authentication is
// enabled iff. remote access is allowed (i.e. the default value of
// “AuthenticationEnabled” equals that of “RemoteAccessAllowed”).
“AuthenticationEnabled” : true,

// The list of the registered users. Because Orthanc uses HTTP
// Basic Authentication, the passwords are stored as plain text.
“RegisteredUsers” : {
// “alice” : “alicePassword”,
// “admin” : “adminPassword”,

Please check my last message