Install Osimis Webviewer On Ubuntu 18.04

How to build Osimis Webviewer plugin On Ubuntu 18.04??

Please check out the following page:


Not sure this is the “correct” way to get the .so file, but I think you can clone and then start the docker image from Osimis.

Go here to get the docker image and clone to your UBUNTU install:

You’ll have to install git.

sudo apt install git

and also docker.

There are some detailed instructions on how to install Docker on UBUNTU here:

After that is installed and git is installed you can clone the Osimis Docker image here:

There is some info about running the Osimis docker images here:

After that change to the Osimis Docker image directory and run something like:

sudo docker run --publish=80:8042 --publish=104:4242 --env=WVB_ENABLED=true --name Orthanc osimis/orthanc

(Please also see that last few comments in this post because you might be able to bypass some of the items below, but it is nice to know how to explore a running Docker image. Also, the Osimis Wiki has some info about using a Storage directory on you system.)

I’ve actually compiled and installed everything on a clean install of UBUNTU. That takes awhile, and the Docker Images have some real advantages.

That should start the container with Explorer running on port 8042 and the Web Viewer Enabled. I had trouble accessing the web viewer, probably because I am running on a VM for UBUNTU, but Orthanc does start.

You should see something like:

. . .

W0702 13:36:18.554109 PluginsManager.cpp:269] Registering plugin ‘osimis-web-viewer’ (version
W0702 13:36:18.554269 PluginsManager.cpp:168] Initializing the Web viewer
W0702 13:36:18.554792 PluginsManager.cpp:168] Using GDCM instead of the DICOM decoder that is built in Orthanc
W0702 13:36:18.555196 OrthancInitialization.cpp:301] SQLite index directory: “/var/lib/orthanc/db”
W0702 13:36:18.556499 OrthancInitialization.cpp:376] Storage directory: “/var/lib/orthanc/db”
W0702 13:36:18.576403 HttpClient.cpp:1066] HTTPS will use the CA certificates from this file: /etc/ssl/certs/ca-certificates.crt
W0702 13:36:18.577191 LuaContext.cpp:104] Lua says: Lua toolbox installed
W0702 13:36:18.577574 LuaContext.cpp:104] Lua says: Lua toolbox installed
W0702 13:36:18.577718 ServerContext.cpp:370] Disk compression is disabled
W0702 13:36:18.577840 ServerIndex.cpp:1636] No limit on the number of stored patients
W0702 13:36:18.577869 ServerIndex.cpp:1653] No limit on the size of the storage area
W0702 13:36:18.578371 JobsEngine.cpp:283] The jobs engine has started with 2 threads
W0702 13:36:18.579026 main.cpp:1109] DICOM server listening with AET ORTHANC on port: 4242
W0702 13:36:18.579089 HttpServer.cpp:1309] HTTP compression is enabled
W0702 13:36:18.579135 main.cpp:974] ====> HTTP authentication is enabled, but no user is declared. Creating a default user: Review your configuration option “RegisteredUsers”. Your setup is INSECURE <====
W0702 13:36:18.579173 main.cpp:1011] Remote LUA script execution is disabled
W0702 13:36:18.584063 HttpServer.cpp:1216] HTTP server listening on port: 8042 (HTTPS encryption is disabled, remote access is allowed)
W0702 13:36:18.584140 main.cpp:814] Orthanc has started

in the terminal.

To explore that running Docker image you can type:

sudo docker exec -it Orthanc bash

and that will put you into a bash shell for the running Docker image with a name of Orthanc.

Navigate to /usr/share/orthanc/plugins, and you’ll see that the Osimis webviewer and gdcm .so files are there:

To exit out of the Docker bash shell you can just type: exit, and you’ll be back in the UBUNTU shell.

You can then type the following in the UBUNTU shell with the paths adjusted for what is on your system. That should copy the .so file to where you specify.

sudo docker cp Orthanc:/usr/share/orthanc/plugins/ /home/parallels/Desktop

I’m actually not sure if you even have to have the image running, but I ran: sudo docker stop Orthanc and then tried

docker cp Orthanc:/usr/share/orthanc/plugins/ /home/parallels/Desktop and that seemed to work also. You’ll still have to install docker and the docker image though.

I think you can probably compile from source also using the files in the repo from Osimis.