import failed with the dicom files , could anyone help?

Hi ,

I used the “” to import the dynamic dicom files, and it showd as the picture

the failure is dynamic dicom as the attachment.
I have tried to import by html web but still failed

could anyone help?

is it the problem of the compressed dicom ?

042647_205234_00010.DCM (4.8 MB)

Your DICOM imports perfectly fine:

$ python ~/Subversion/orthanc/Resources/Samples/ImportDicomFiles/ localhost 8042 Downloads/042647_205234_00010.DCM
Importing Downloads/042647_205234_00010.DCM => success

Summary: all 1 DICOM file(s) have been imported successfully

Have a look at your logs in “–verbose” mode:

There were issues with the importing script when using Python 3 and if your Orthanc installation requires authentication. This is now fixed in the mainline source code.

However, since you wrote that the upload also fails in the Orthanc Explorer, the problem probably lies somewhere else.

Thanks for help.

I found the problem is related to google cloudsql postgresql settings .

the size of the Dicom is 386MB , so big to postgresql default settings.

Could anyone help supply the better postgresql flag setting ?

one of these issues I have found is as belows

`work_mem` (`integer`)

Specifies the amount of memory to be used by internal sort operations and hash tables before writing to temporary disk files. The value defaults to four megabytes (4MB). Note that for a complex query, several sort or hash operations might be running in parallel; each operation will be allowed to use as much memory as this value specifies before it starts to write data into temporary files. Also, several running sessions could be doing such operations concurrently. Therefore, the total memory used could be many times the value of work_mem; it is necessary to keep this fact in mind when choosing the value. Sort operations are used for ORDER BY, DISTINCT, and merge joins. Hash tables are used in hash joins, hash-based aggregation, and hash-based processing of IN subqueries.

Sébastien Jodogne於 2020年4月8日星期三 UTC+8下午3時05分48秒寫道:


Unfortunately, this forum is not about Google Cloud SQL.

Please get in touch with your Google technical support (you pay them for such a support, after all), then share your insight on this forum to the benefit of the Orthanc community.

I would also suggest you to only enable the “index” plugin, and to disable the “storage” plugin, as explained in the FAQ:

Storing large DICOM objects in a SQL database is probably to avoid (if only for the costs).