Horos retrieve problem

Has anybody had any success setting up Horos to Q/R on OSX?

Summary of environment and problem:

host: ip address correct
port 4242

host: tried all IP addresses both a dynDNS address and the current assigned IP…
port: 11112

No problems sending to ORTHANC and dcms are correctly stored when sent from HOROS. I can also search and return results correctly however I absolutely cannot retrieve a thing no matter what configuration I try. I’ve tried reducing all security settings in the config to make Orthanc as loose as possible in acceptance of remote modalities.

Orthanc terminal reports this:

W0827 13:57:07.828035 OrthancMoveRequestHandler.cpp:261] Move-SCU request received for AET “HOROS”

E0827 13:57:17.838779 DicomUserConnection.cpp:167] DicomUserConnection: Failed to establish association

0006:0317 Peer aborted Association (or never connected)

0006:031c TCP Initialization Error: Operation now in progress (Timeout)

I’ve also tried all of the above in a localhost environment on my Mac on OSX High Sierra and the problem is identical.

I also cannot intitiate a send from the web instance of Orthanc to the (listed) HOROS remote modality location and C-ECHO fails when I test from the web.

My Mac firewall is open and the port 11112 is also open.

The error I get in Horos is:
DICOM Network Failure (query)
SCU Failed 0006:0208 DIMSE No valid Presentation Context ID

I know this ain’t a Horos support forum but this is a pretty common piece of software nowadays and I’d like to know if anybody has successfully set up Horos to work with either a cloud instance of Orthanc or a Local one?

FWIW I also tried OsiriX HD on iPad and it fails

Best wishes


Yes, Horos and Orthanc are known to work correctly together.

The fact that Horos mentions " SCU Failed 0006:0208 DIMSE No valid Presentation Context ID" means that, at least, Horos and Orthanc are connected which is already a good news.

This DICOM negotation problem would appear if the file you’re trying to send/retrieve is not accepted by Horos. Is there anything special about the file you’re trying to send ?

In Orthanc, there’s an option to make it accept “anything”; maybe there’s an equivalent in Horos ?

// Whether Orthanc accepts to act as C-Store SCP for unknown storage
  // SOP classes (aka. "promiscuous mode")
  "UnknownSopClassAccepted"            : false,


Rephrasing Alain’s answer, the most plausible explanation is indeed that the DICOM files you are trying to send from Orthanc to Horos, have a transfer syntax or a SOP class UID that is not accepted by Horos.

Give a try sending an uncompressed DICOM file that encodes for instance a plain RX.

Furthermore, carefully inspect the Orthanc logs in “–verbose” mode, as well as the Horos logs: