gui won't open, can't send to orthanc from machine

I’m a orthanc beginner & am trying to get it working.
I have 3 problems:

  1. orthanc explorer won’t open (in ie or chrome)
  2. can I use unc path for storage directory?
  3. can’t send to orthanc from a phillips c arm machine, trying to do dicom export from phillips to orthanc.

I ran the installer(orthanc win64 21.7.0), i changed the storage directory to a unc path \myservername\orthanc during installer (is this allowed?). Install completes fine, but…I can’t get orthanc explorer to open up, it just gives a “page cannot be displayed” error. I checked the config folder and I don’t see a configuration.json file like the orthanc book says there should be, but the orthanc.json file appers to be the same thing. I opened it and checked and I see the default port 8042 for http & i also see my storage directory, but it shows as: \\myservername\orthanc (so it added two extra \ at the beginning and one extra \ after the server name…Is this correct? I turned off windows firewall for testing purposes and also did a telnet test to 4242, 8042 and 104 and connection failed to all of them, so something isn’t running because the orthanc server isn’t listening on any of these ports. I am however able to ping the orthanc server fine.

Any help would be appreciated.

also worth noting, I’m running orthanc on a hyper-v vm running server 2012 r2 standard 64bit with 4gb ram. I checked to make sure the orthanc service is running and it is.

As a Orthanc beginner, I can say that the web gui is very picky about how you change your configuration files. I had similar problems when trying to modify some of the .json config files, but the fault was in my end, with some small mistakes.

For the GUI part: first try with “RemoteAccessAllowed”: true and “AuthenticationEnabled”: false. If you still can’t access it that means that it’s not running or it’s likely a firewall/port sharing issue.

For UNC: I can’t tell; I’ve never tried but I think that some people use UNC paths together with NAS storage.

For DICOM connectivity issue: check the logs to make sure Orthanc is listening on 4242. If telnet can’t connect, it probably also means it’s a firewall/port sharing issue.