DicomWeb not working, 404 error.

When I curl, I get 404 response

“HttpError” : “Not Found”,
“HttpStatus” : 404,
“Message” : “Unknown resource”,
“Method” : “GET”,
“OrthancError” : “Unknown resource”,
“OrthancStatus” : 17,
“Uri” : “/dicom-web/studies/”

I’m using ubuntu 16.04

I installed the official Orthanc plugin from here and complied it using these instructions and added it to orthanc.json. I also added server-related options to my orthanc.json.

PS: It works in windows without having to install any additional plugins or making changes to configuration file.

Hi saip,

Can you post your startup logs and try starting Orthanc with --verbose/–trace? The loading (or failure thereof) pops as a warning. Still, we might be talking of something else, that’s why the verbose and trace.


How do I get the startup logs?
I ran Orthanc --verbose and got the following response

W0704 14:51:28.441565 main.cpp:1129] Orthanc version: 1.0.0
W0704 14:51:28.443036 OrthancInitialization.cpp:228] Using the default Orthanc configuration
W0704 14:51:28.443062 HttpClient.cpp:386] No certificates are provided to validate peers, set “HttpsCACertificates” if you need to do HTTPS requests
W0704 14:51:28.450981 FromDcmtkBridge.cpp:148] Loading the external DICOM dictionary “/usr/share/libdcmtk5/dicom.dic”
W0704 14:51:28.458382 FromDcmtkBridge.cpp:148] Loading the external DICOM dictionary “/usr/share/libdcmtk5/private.dic”
W0704 14:51:28.464146 OrthancInitialization.cpp:420] Registering JPEG Lossless codecs
W0704 14:51:28.464172 OrthancInitialization.cpp:425] Registering JPEG codecs
W0704 14:51:28.470736 OrthancInitialization.cpp:910] SQLite index directory: “/home/user/OrthancDicomWeb-0.5/Build/OrthancStorage”
W0704 14:51:28.470995 OrthancInitialization.cpp:980] Storage directory: “/home/user/OrthancDicomWeb-0.5/Build/OrthancStorage”
I0704 14:51:28.471559 DatabaseWrapper.cpp:307] Version of the Orthanc database: 6
W0704 14:51:28.471808 ServerScheduler.cpp:134] The server scheduler has started
I0704 14:51:28.471818 ServerIndex.cpp:1857] Starting the monitor for stable resources (stable age = 60)
I0704 14:51:28.471913 ServerIndex.cpp:365] Starting the database flushing thread (sleep = 10)
W0704 14:51:28.472092 LuaContext.cpp:103] Lua says: Lua toolbox installed
I0704 14:51:28.472142 HttpClient.cpp:412] Setting the default timeout for HTTP client connections: 0 seconds
W0704 14:51:28.472163 ServerContext.cpp:168] Disk compression is disabled
I0704 14:51:28.472174 ServerContext.cpp:447] Storing MD5 for attachments: yes
W0704 14:51:28.472186 ServerIndex.cpp:1372] No limit on the number of stored patients
W0704 14:51:28.472217 ServerIndex.cpp:1389] No limit on the size of the storage area
E0704 14:51:28.472497 DicomServer.cpp:304] cannot create network: TCP Initialization Error: Address already in use
I0704 14:51:29.471981 ServerIndex.cpp:1901] Closing the monitor thread for stable resources
I0704 14:51:29.472037 ServerIndex.cpp:383] Stopping the database flushing thread
E0704 14:51:29.473214 main.cpp:1169] Uncaught exception, stopping now: [The TCP port of the DICOM server is already in use] (code 2004)
W0704 14:51:29.473682 main.cpp:1202] Orthanc has stopped

I realize this is happening because I already have the orthanc service running on the same port. However can you please tell me how to get the logs, what is the exact command for it? Thannks. Or should I stop the service and use the same command that I tried?

Yes, just stop the service and restart Orthanc with --verbose option (http://book.orthanc-server.com/faq/log.html)

Also make sure that the plugin is really loaded by opening the plugins page in the Orthanc Explorer.