Connect ultrasound Machine Kalamed KUP-111+ to orthanc pacs server

Hi I have a ultrasound machine Kalamed KUP-111+ that i want to connect to orthanc server.
I have installed orthanc in my windown 10 laptop and changes remote access allowded to true in configuration.
My laptop is connected to a router via wifi. I have used a cable to connect ultrasound machine to the router. Please any one can help me set this up. I cannot even get a echo verification.

My wireless adaper ip is and dicom port is set as default to 4242.

I have attached a screenshot of my ipconfig and kalamed dicom preset screen.
Any input would be highly appriciated




It kind of depends upon how your router is setup. Sound like you are using Wi-Fi for the laptop, and a cable for the US Unit ? If they are both on the same subnet, then it might work, but I would just use a cable for both initially, and I would recommend not using Wi-Fi period, except maybe under some special circumstance.

Looking at your photo, you have for the US unit, port 2000, and for Orthanc, port 4242, which is a little confusing really, probably because you say you are using Wi-Fi.

Also, you need to setup your modalities in the Orthanc orthanc.json file.

A default configuration file can be found here with detailed comments: Default Config and see here also: Configuration of Orthanc

Look at line 309 in the Default Config and read through the Orthanc Book documentation, and check back if you are still having issues.

You have to make sure that you don’t have any of the ports that you are using blocked either. I don’t use Windows, but for initial testing, you might want to just turn the Windows Firewall off, or otherwise enable the ports that you are using for your setup.

Hi stephen your help is much appreciated. I have connected both (ultrasound unit and my laptop) using cable connection like you said and have windows firewall turned off in my laptop. The port is also open. I have also setup modalities in orthanc.json file. But still i get “echo failed” when trying to validate connection. I have attached the screen shot of configuration file along with the screenshot of ipconfig also. Please Help me as I am completly lost on what else to do.

I work for a non profit and we are trying to implement some technology in hospitals in rural areas in Nepal. This is not my expertise. But we are trying our best to do what we can. Hospitals here still do not have any sort of pacs server and trasfer of data and images are done through whatsapp and other unreliable medium. Any help is highly appreciated as it would help a lot of people in need and help to devlop health care in needy places. Thankyou soo much.

configuration file.PNG


orthanc.json (32.8 KB)



The Orthanc Book contains a guide to troubleshoot DICOM communications:

You should notably make sure that the network firewalls don’t block communications using the 4242 and 104 TCP ports (that are used for DICOM communications). Get in touch with your network administrators.