Can't get a response on C-Find request

I try to do C-Find request from my C# application (using fo-dicom ) to Orthanc server (hosted on the same PC and worked with DICOMweb requests), but get an exception:
"Dicom.Network.DicomAssociationAbortedException: "Association Abort [source: Unknown; reason: NotSpecified]"

I tried "fo-dicom-examples\QueryRetrieve SCU" project and it works with default server, but with my server it gives the same exception:

private static string QRServerHost = "";
private static int QRServerPort = 4242;
private static string QRServerAET = "ORTHANC";
private static string AET = "FODICOMSCU";

var client = new DicomClient();
var request = CreateStudyRequestByPatientName("MISTER^CT*");
client.Send(QRServerHost, QRServerPort, false, AET, QRServerAET);

Orthanc server has default configuration.
Any ideas what can be wrong?

I’m using Orthanc server (v17.6.1) on Win10 and C# application with fo-docom (v3.0.0).

I figured out how to use C-Find and C-Move (problem was in not working local AET), but now I have a problem with C-GET:

I tried to use C-GET example from fo-dicom-samples repository with my Orthanc server:

var cGetRequest = CreateCGetBySeriesUID(studyUID, serieUids.First());
client.OnCStoreRequest += (DicomCStoreRequest req) =>
return new DicomCStoreResponse(req, DicomStatus.Success);

DicomUID.DigitalXRayImageStorageForPresentation, DicomTransferSyntax.ImplicitVRBigEndian,
DicomTransferSyntax.ExplicitVRBigEndian, DicomTransferSyntax.ExplicitVRLittleEndian));
client.Send(QRServerHost, QRServerPort, false, AET, QRServerAET);

but “client.OnCStoreRequest” event even not fired. then I added handler for “request.OnResponseReceived” and got an error in the response:

{Failure [0122: Refused: SOP class not supported]}
Code: 290
State: Failure

Log of Orthanc doesn’t have any new messages after request.

I checked that added SopClassUID for AdditionalPresentationContext is correct, but strange, that instances in the Orthanc don’t have TransferSyntax tag, can it be a reason of the problem?

I just read that C-GET isn’t supported by Orthanc, then I have no questions anymore.


Indeed, supporting C-Get is on our roadmap: