Unicode chars in the C-Find

Just recompiled and updated 1Tb database from 0.8.6 to 1.3.1

Here is the problem…
Look at the PatientName:

curl -X POST http://localhost:8042/modalities/local/query -d ‘{“Level”:“Patient”,“CaseSensitive”:false,“Query”:{“PatientName”:“123Петрова*”}}’

I0306 11:02:44.078452 OrthancFindRequestHandler.cpp:558] DICOM C-Find request at level: Patient
I0306 11:02:44.078520 OrthancFindRequestHandler.cpp:564] (0008,0005) SpecificCharacterSet = ISO_IR 100
I0306 11:02:44.078576 OrthancFindRequestHandler.cpp:564] (0008,0052) QueryRetrieveLevel = PATIENT
I0306 11:20:51.738025 OrthancFindRequestHandler.cpp:564] (0010,0010) PatientName = 123*

I0306 11:20:51.738063 OrthancFindRequestHandler.cpp:564] (0010,0020) PatientID =
I0306 11:20:51.812557 OrthancFindRequestHandler.cpp:637] Number of candidate resources after fast DB filtering: 0
I0306 11:20:51.812663 OrthancFindRequestHandler.cpp:663] Number of matching resources: 0

Hello,

In the configuration file of Orthanc, set the “DefaultEncoding” option to “Utf8”.

By default, Orthanc uses Latin-1 encoding, in which the characters of your query cannot be encoded.

Regards,
Sébastien-

My bad. Thanks.
Solved :slight_smile: