Unable to login to orthanc on CentOS

Using CentOS. Have multiple folders with dicom files in it. Trying to host these folders under Orthanc Server

Followed instructions from LinuxCompilation.txt to build

Created Configuration.json in /OrthancBuilder/

Started by running ./Orthanc --verbose

Below are the changes I made to login to orthanc server remotely

/**

  • Security-related options for the HTTP server
    **/

// Whether remote hosts can connect to the HTTP server
“RemoteAccessAllowed” : true,

// Whether or not SSL is enabled
“SslEnabled” : false,

// Path to the SSL certificate in the PEM format (meaningful only if
// SSL is enabled)
“SslCertificate” : “certificate.pem”,

// Whether or not the password protection is enabled
“AuthenticationEnabled” : true,

// The list of the registered users. Because Orthanc uses HTTP
// Basic Authentication, the passwords are stored as plain text.
“RegisteredUsers” : {“test” : “test”},

Unable to login with the credentials specified. Not sure if I’m missing something with any configuration.

This is most probably a firewall problem, please have a look at the following FAQ:
https://book.orthanc-server.com/faq/redhat.html

HTH,
Sébastien-

Thank You for getting back Sébastien! I already did open the ports and when tried to access http://hostname:8042 was presented with a login dialog. Entering the credentials just clears the username and password fields with dialog open but nothing happens. Not sure if I am missing any other necessary configuration. Any idea where I could find the logs? I’m running othanc from inside OrthancBuild folder

Okay it worked when I started by ./Orthanc Configuration.js. Searching for the log file to be able to understand and debug issues.