Unable to launch Mongoose server

Brand new debian install of 0.8.3 on Ubuntu 14.04. Install went fine however when running sudo Orthanc ./Configuration.json it runs thru everything but bombs out at the following

W1002 10:17:57.842130 23656 main.cpp:471] Storage directory: "./OrthancStorage"
E1002 10:17:58.972059 23656 main.cpp:618] Uncaught exception, stopping now: [Unable to launch the Mongoose server]
W1002 10:17:58.972359 23656 main.cpp:629] Orthanc has stopped

Any suggestions?

BTW Fairly a noob with Linux but slowly figuring it out.

Hello,

How did you install Orthanc? From source, or from the official Debian package?

In the latter case (official package), the configuration can be found in “/etc/orthanc/orthanc.json”, and the Orthanc service must be started with “sudo /etc/init.d/orthanc start”.

In the former case (build from source), what is the content of “./Configuration.json”?

Regards,
Sébastien-

I am having the same issue. I built from source on 14.04 but if I try to run "Orthanc" I get the same error. If I run "Orthanc ./Configuration.json" from the 'default' configuration file (found here: https://bitbucket.org/sjodogne/orthanc/raw/Orthanc-1.0.0/Resources/Configuration.json) I get the same error. Any ideas?

Hello,

Please post the full log with “–verbose” flag.

Make sure that no other process is listening to port 8042 or 4242 by running the following command:

sudo netstat -tulnp

Regards,
Sébastien-

Checked the ports, both 8042 and 4242 are both open.

Running Orthanc with the --verbose flag yields:

W0404 09:21:31.447192 4354 OrthancInitialization.cpp:62] Using the configuration from: ./Configuration.json
I0404 09:21:31.450582 4354 DatabaseWrapper.cpp:820] Version of the Orthanc database: 3
I0404 09:21:31.450819 4356 ServerIndex.cpp:1457] Starting the monitor for stable resources (stable age = 60)
I0404 09:21:31.450860 4355 ServerIndex.cpp:267] Starting the database flushing thread (sleep = 10)
I0404 09:21:31.450978 4354 LuaContext.cpp:80] Lua says: Lua toolbox installed
W0404 09:21:31.451004 4354 main.cpp:327] Storage directory: "./OrthancStorage"
W0404 09:21:31.451016 4354 main.cpp:328] Index directory: "./OrthancStorage"
W0404 09:21:31.451028 4354 ServerContext.cpp:76] Disk compression is disabled
W0404 09:21:31.451040 4354 ServerIndex.cpp:1034] No limit on the number of stored patients
W0404 09:21:31.451068 4354 ServerIndex.cpp:1051] No limit on the size of the storage area
W0404 09:21:31.451122 4354 main.cpp:400] DICOM server listening on port: 4242
W0404 09:21:31.451134 4354 main.cpp:401] HTTP server listening on port: 8042
I0404 09:21:32.451011 4355 ServerIndex.cpp:285] Stopping the database flushing thread
I0404 09:21:32.451011 4356 ServerIndex.cpp:1501] Closing the monitor thread for stable resources
E0404 09:21:32.455433 4354 main.cpp:426] EXCEPTION [Unable to launch the Mongoose server]

Hello,

According to the logs, your instance of Orthanc uses the database version 3, which indicates that you run a very old version of Orthanc (between 0.4.0 and 0.7.2, that were released before December, 2013).

Please upgrade to Orthanc 1.0.0 before we can provide any further help.

Regards,
Sébastien-

I built this from the most recent source here: http://www.orthanc-server.com/download.php

Is there anything I need to do get to the latest version?

Visibly, you aren’t running the most recent version, presumably because of an older version of Orthanc sitting in your PATH environment variable.

Make sure to run “./Orthanc” in the build directory (and not “Orthanc”).

Adding the “–version” flag will display what is the version of Orthanc you are using.

Figured it out: the older version was also installed through the Ubuntu software system on my machine. I cleared that out and it works as hoped.

Thanks!