Testers wanted! Orthanc on openSUSE

Dear all,

the porting of Orthanc to openSUSE is getting close to ‘done’ - thanks to the help from Sebastien!

Before we move it into an official repository I would like to ask you for some additional quality assurance/testing.

  1. get a copy of openSUSE Leap 15.1 (or another flavour - Leap 15.0, Tumbleweed or SLE) from https://www.opensuse.org/

  2. Install it, maybe in a virtual machine

  3. Add the Orthanc-Repo like this

sudo zypper ar -f https://download.opensuse.org/repositories/home:/DocB:/Orthanc/openSUSE_Leap_15.1 orthanc

  1. install Orthanc: sudo zypper in orthanc (and maybe the plugins?)

  2. Report back any issues you find

Thank you!
Axel

Hi Axel, this is exciting news!

I’m really looking forward to feedback from openSUSE users!

Thanks for all your hard work,
Sébastien-

Hi Axel

Thanks for your work!

I am not an OpenSUSE user, but since it’s very easy to install it using Windows subsystem for Linux, I gave it a try.

I added the repo, but there was a problem when I tried to actually install Orthanc :

opensuse-orthanc-install-error.png

I do not know if this seems be related to WSL usage… Is there anything obvious I should try?

Sorry for the image size. Here’s a legible version.

opensuse-orthanc-install-error.png

Here’s the list of repos. BTW I am using the App Store version (OpenSUSE Leap 15.1)

bgo@DELLBGO9570:~> zypper lr -d

| Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service

Hello Benjamin,

thanks for testing.

Haha :slight_smile: You are correct. To Microsoft credit, this WSL things usually works very nicely.

The only reason I keep Windows is the Visual Studio debugger (haven’t found anything as nice under Linux yet) :slight_smile:

I will give it another try using a VM later (right now I am fighting a brave bug that simply refuses to die)

Hi Axel,

Successfully installed on OpenSuse Leap 15.1

How do I install the plugins?

Ronald

Hello Ronald

nice to meet you here as well :slight_smile:

Hi Axel,

Successfully installed on OpenSuse Leap 15.1

How do I install the plugins?

zypper install OrthancPostgreSQL OrthancDicomWeb