Storage and Index directories

I have the Orthanc Storage and Index directories set up like this (accidentally):
Storage directory: OrthancStorage (which is inside the Orthan Build folder on the primary hard drive under the home directory)
Index Directory: /a_secondary_hard_drive/OrthancStorage

I wanted to have both of them point to the OrthanStorage folder in the secondary hard drive.
How can I fix it now?

Also, do you think my current setting is causing the upload process to be slower? I am experiencing a slow upload speed since the initiation of this instance of Orthanc. There are also some issues with web access.

Please advise.

Thanks,

Eyesha

Stop Orthanc,
Move your data from one place to the other
Update your Orthanc configuration file to point to the new locations
Restart Orthanc

I am sorry for responding this late.
Thank you for the help.
I am wondering if this situation (having the two directories totally separate from each other) if affecting the upload speed.
Since the beginning of this setup, we are experiencing historically slow upload speeds.

Best

I am sorry for responding this late.
Thank you for the help.
I am wondering if this situation (having the two directories totally separate from each other) if affecting the upload speed.
Since the beginning of this setup, we are experiencing historically slow upload speeds.

Best,

No, using a single folder or two does not make any difference wrt performance.

Could you suggest something that might be causing a slowdown?
I am also facing difficulty in retrieving the data off-site using a curl script. Again this is something that I could do with my previous setup.
I can’t figure out any difference between this instance of Orthanc and the one before it. Except that this one is set up on a Linux machine while the previous one was on Ubuntu.

Thanks.

If you expect feedback, I think you should provide details.

Have you checked the log files for errors ? What’s your configuration ? …
What do you mean by “facing difficulty” ??? How do you observe the “slowdown” ???

What have you tried so far ?

  • My configuration is the default configuration. I have not changed anything except the location of the storage directory and remote access authentication details.

  • As for ‘facing difficulty’, I can download the data from a remote location (manually) most of the time. However, sometimes I can’t- I see the data or the folder that I need to download, but when I click on it to download, I get an error message pointing to the internal server error. I am sorry that I didn’t save the error message.

  • When I use my curl json script to download a few series, this is what I get. (This is luckily auto-saved by my script to save my day). {

“HttpError” : “Internal Server Error”,
“HttpStatus” : 500,
“Message” : “The specified path does not point to a regular file”,
“Method” : “POST”,
“OrthancError” : “The specified path does not point to a regular file”,
“OrthancStatus” : 2006,
“Uri” : “/tools/find”
}

I have not tried anything yet for any of the two issues (1-slow upload and 2-download problems).

I was thinking that the storage directory and index directory locations might be contributing to the slow upload. But as you said, and I have verified after moving the data and fixing the configuration file accordingly, that the speed is not affected.

The download problems in the manual download come and go. And hence I am able to manage (although I feel annoyed when I can’t download).
My curl script has not been successful so far since the move of my Orthanc server from Ubuntu to Arch Linux.

I am thankful for your help.

From the error message, I can tell you that:

  • either some files are missing after you’ve moved your Orthanc setup from one server to the other
  • or Orthanc does not have the rights to read some files