Slow down in dicom transfer to Orthanc

Hi,
Firstly thanks for a great software.

I am using Orthanc 1.1 built on Linux Mint. It is working well, but I have noticed transfer speeds from the scanner have slowed a lot. I am looking for ways to improve performance and have a couple of queries about this:

Firstly, I built and installed with default build type of DEBUG. I would like change to RELEASE. Is the correct procedure for this:

  • Build and install RELEASE build.
  • Transfer all files from original, DEBUG build to RELEASE build
  • Remove DEBUG build.
    (or is it possible to build and install RELEASE version and point to original Config setup?)

Are there any other tricks I can apply to improve transfer speed?
Is regularly deleting the “changes” file a good option?

As a note, we receive a large number of images, currently at >500K from 25 subjects (>80GB).
I plan to export, archive and delete regularly but obviously a single day of scanning can load up the images very quickly.

Thanks a lot,
Fraser

Hello,

Firstly, I built and installed with default build type of DEBUG. I would like change to RELEASE. […]
(or is it possible to build and install RELEASE version and point to original Config setup?)

Yes: Debug and Release versions are fully interchangeable (of course provided they correspond to the same version of Orthanc.

Are there any other tricks I can apply to improve transfer speed?

Performance issues are discussed in the FAQ:
http://book.orthanc-server.com/faq/troubleshooting.html#performance-issues

Is regularly deleting the “changes” file a good option?

There is no such a “changes” file: The entire Orthanc index is stored inside a single SQLite database.

As a note, we receive a large number of images, currently at >500K from 25 subjects (>80GB).

As discussed in the FAQ above, as soon as your number of images (“instances”) grow over 50,000, which is clearly your case, switching to PostgreSQL will greatly improve the performance of Orthanc.

HTH,
Sébastien-

Hi,
Thanks so much for your reply.

Unfortunately a switch to PostgreSQL has shown no improvement. Transfer speed is still of the order of 40-60 minutes for a study (Osirix equivalent is < 5 minutes).

Same slow speeds are experienced during a study export to the local file system.

I have tried the set up on multiple systems and following instructions found at:
http://book.orthanc-server.com/plugins/postgresql.html#postgresql
and the slightly different Debian Med instructions:
https://anonscm.debian.org/viewvc/debian-med/trunk/packages/orthanc-postgresql/trunk/debian/README.Debian?view=markup

Are there any tips regarding DB optimisation or Orthanc parameters tweaking that I could explore?

Thanks a lot,
Fraser

I should add that I have tested with dcmtk from the repositories (Linux Mint 18 / Ubuntu Xenial) ( DCMTK v 3.6.1) and statically linked (v3.6.0).
Same performance.

Thanks

Hello,
I have done some more testing and found a large speedup by setting “EnableStorage” to false under the PostgreSQL plugin configuration.
Now transferring approx 15000 files in 20 mins (roughly 200MB per minute).

I don’t see any real negatives, with respect to our usage, by having EnableStorage set to false. File access, export etc still behaves fine. Though I am not very familiar with PostgreSQL.

I welcome any other comments with regards to this setup, but the current status works well for us and unless I am missing anything important I am happy to close this discussion.

Thanks,
Fraser