simple setup problem

Hi, I'm new to DICOM servers...

I am trying to set up an Orthanc server on my Windows 7 machine in order to communicate with an ultrasound system.

I can successfully ping my Windows 7 machine from the ultrasound system, and I can successfully ping the ultrasound system from the Windows machine, but after I start Orthanc and use the ultrasound system to attempt to verify the association, I get the following messages on the Windows machine:

       Unknown remote DICOM modality AET: "epiq01"
       Echo requests are disallowed for the AET "epiq01"

Nothing happens for a little while (15 seconds?) and then the following errors show up:

       DIMSE failure (aborting association): DIMSE No data available (timeout in non-blocking mode)

Any help would be greatly appreciated!

Thanks,
Steven

My configuration file looks like this (with the IP address in DicomModalities replaced with x's):

{
  /**
   * General configuration of Orthanc
   **/

  // The logical name of this instance of Orthanc. This one is
  // displayed in Orthanc Explorer and at the URI "/system".
  "Name" : "DICOMserver_Orthanc_Windows",

  // Path to the directory that holds the heavyweight files
  // (i.e. the raw DICOM instances)
  "StorageDirectory" : "F:/Orthanc DICOM data",

  // Path to the directory that holds the SQLite index (if unset,
  // the value of StorageDirectory is used). This index could be
  // stored on a RAM-drive or a SSD device for performance reasons.
  "IndexDirectory" : "F:/Orthanc DICOM data",

  // Enable the transparent compression of the DICOM instances
  "StorageCompression" : false,

  // Maximum size of the storage in MB (a value of "0" indicates no
  // limit on the storage size)
  "MaximumStorageSize" : 0,

  // Maximum number of patients that can be stored at a given time
  // in the storage (a value of "0" indicates no limit on the number
  // of patients)
  "MaximumPatientCount" : 0,
  
  // List of paths to the custom Lua scripts to load into this
  // instance of Orthanc
  "LuaScripts" : [
  ],

  /**
   * Configuration of the HTTP server
   **/

  // HTTP port for the REST services and for the GUI
  "HttpPort" : 8042,

  /**
   * Configuration of the DICOM server
   **/

  // The DICOM Application Entity Title
  "DicomAet" : "ORTHANC",

  // Check whether the called AET corresponds during a DICOM request
  "DicomCheckCalledAet" : true,

  // The DICOM port
  "DicomPort" : 4242,

  /**
   * Security-related options for the HTTP server
   **/

  // Whether remote hosts can connect to the HTTP server
  "RemoteAccessAllowed" : true,

  // Whether or not SSL is enabled
  "SslEnabled" : false,

  // Path to the SSL certificate (meaningful only if SSL is enabled)
  "SslCertificate" : "certificate.pem",

  // Whether or not the password protection is enabled
  "AuthenticationEnabled" : false,

  // The list of the registered users. Because Orthanc uses HTTP
  // Basic Authentication, the passwords are stored as plain text.
  "RegisteredUsers" : {
    "tcsapo" : "us"
  },

  /**
   * Network topology
   **/

  // The list of the known DICOM modalities
  "DicomModalities" : {
    /**
     * Uncommenting the following line would enable Orthanc to
     * connect to an instance of the "storescp" open-source DICOM
     * store (shipped in the DCMTK distribution) started by the
     * command line "storescp 2000".
     **/
    // "sample" : [ "STORESCP", "localhost", 2000 ]
    "epiq01" : [ "epiq01", "xxx.xx.xxx.xxx", 49394 ]

    /**
     * A fourth parameter is available to enable patches for a
     * specific PACS manufacturer. The allowed values are currently
     * "Generic" (default value), "ClearCanvas", "MedInria" and
     * "Dcm4Chee". This parameter is case-sensitive.
     **/
    // "clearcanvas" : [ "CLEARCANVAS", "192.168.1.1", 104, "ClearCanvas" ]
  },

  // The list of the known Orthanc peers
  "OrthancPeers" : {
    /**
     * Each line gives the base URL of an Orthanc peer, possibly
     * followed by the username/password pair (if the password
     * protection is enabled on the peer).
     **/
    // "peer" : [ "http://localhost:8043/", "alice", "alicePassword" ]
    // "peer2" : [ "http://localhost:8044/" ]
  },

  /**
   * Advanced options
   **/

  // Dictionary of symbolic names for the user-defined metadata. Each
  // entry must map a number between 1024 and 65535 to an unique
  // string.
  "UserMetadata" : {
    // "Sample" : 1024
  },

  // Dictionary of symbolic names for the user-defined types of
  // attached files. Each entry must map a number between 1024 and
  // 65535 to an unique string.
  "UserContentType" : {
    // "sample" : 1024
  },

  // Number of seconds without receiving any instance before a
  // patient, a study or a series is considered as stable.
  "StableAge" : 60,

  // Enable the HTTP server. If this parameter is set to "false",
  // Orthanc acts as a pure DICOM server. The REST API and Orthanc
  // Explorer will not be available.
  "HttpServerEnabled" : true,

  // Enable the DICOM server. If this parameter is set to "false",
  // Orthanc acts as a pure REST server. It will not be possible to
  // receive files or to do query/retrieve through the DICOM protocol.
  "DicomServerEnabled" : true,

  // By default, Orthanc compares AET (Application Entity Titles) in a
  // case-insensitive way. Setting this option to "true" will enable
  // case-sensitive matching.
  "StrictAetComparison" : false,

  // When the following option is "true", the MD5 of the DICOM files
  // will be computed and stored in the Orthanc database. This
  // information can be used to detect disk corruption, at the price
  // of a small performance overhead.
  "StoreMD5ForAttachments" : true
}

Hello,

Please carefully read the DICOM troubleshooting guide in the Orthanc Book, and provide all the requested information (including the full log):
https://orthanc.chu.ulg.ac.be/book/faq/dicom.html

In particular, make sure to issue the C-Echo commands to test DICOM-level connectivity.

As far as I can tell by reading your message, I suspect you do not tell Orthanc to use your configuration file. Orthanc should indeed know about “epiq01” if it were provided the right configuration.

Also double-check whether the AET of your US modality is “epiq01” (with a zero) or “epiqO1” (with a O letter), and make sure to use the proper case (upper or lower).

HTH,
Sébastien-