osimis build 21.5.1 cannot receive data: Unable to check DICOM authorization

Since updating to osimis/orthanc:21.5.1, all DICOM sends into Orthanc fail. This problem does not occur in 21.5.0.

orthanc_1 | W0511 13:28:17.964615 main.cpp:395] Unable to check DICOM authorization for AET mic-dicom-router on IP 172.29.158.75: Its IP address should be mic-dicom-router.mclean.harvard.edu according to configuration option “DicomModalities”

But the IP and name are correct:

$ host mic-dicom-router
mic-dicom-router.mclean.harvard.edu has address 172.29.158.75

$ host 172.29.158.75

75.158.29.172.in-addr.arpa domain name pointer mic-dicom-router.mclean.harvard.edu.

Again, this is not a problem under 21.5.0.

Daniel

The “DicomModalities” configuration option should contain an IP address (“172.29.158.75”), not a fully qualified name (“mic-dicom-router.mclean.harvard.edu”). Orthanc doesn’t do DNS host resolution.

You could also try setting “DicomCheckModalityHost” to “false”.

Ok, I’ll fix that - but why did it work up until 21.5.1?

By the way, the Orthanc Book, at https://book.orthanc-server.com/dicom-guide.html , states:

“3. Its IP address or its hostname.”

(boldface mine)

This is the following NEWS entry of Orthanc 1.9.3:

  • Fix regression in the handling of “DicomCheckModalityHost” configuration option
    introduced by changeset 4182 in Orthanc 1.7.4

Check out the two following changesets:

=> In Orthanc 1.7.4 to 1.9.2, there was no check “it->GetHost() == remoteIp” in the case where “DicomCheckModalityHost == true” and “modalities.size() == 1”.

Ok, then should the Book be changed?

In addition, https://book.orthanc-server.com/faq/security.html says:

  • Set the DicomCheckModalityHost configuration option to true to validate the IP and hostname address of the remote modalities.

Which again seems to imply a hostname can be used.

I have just clarified this sentence by adding a remark about when a hostname can be used:
https://hg.orthanc-server.com/orthanc-book/rev/e932c609c30a

https://book.orthanc-server.com/dicom-guide.html#configuring-orthanc

Got it. Thanks!

Indeed, this is now fixed:
https://hg.orthanc-server.com/orthanc-book/rev/11e536e70b37