# Orthanc upgrade problem (1.3.0 to 1.5.3)

**URL:** https://discourse.orthanc-server.org/t/orthanc-upgrade-problem-1-3-0-to-1-5-3/1317
**Category:** Google Groups archive
**Created:** [February 8, 2019, 3:09am UTC](https://discourse.orthanc-server.org/t/orthanc-upgrade-problem-1-3-0-to-1-5-3/1317 "2019-02-08T03:09:19Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Philippe\_Despres](https://discourse.orthanc-server.org/letter_avatar_proxy/v4/letter/p/b5a626/32.png) [@Philippe\_Despres](https://discourse.orthanc-server.org/u/Philippe_Despres)
#### Post date: [February 8, 2019, 3:09am UTC](https://discourse.orthanc-server.org/t/orthanc-upgrade-problem-1-3-0-to-1-5-3/1317/1 "2019-02-08T03:09:19Z")

</div>

Hi,

I am trying to migrate from 1.3.0 to 1.5.3.

Orthanc won’t start (I am using the --upgrade option) , with the following error:

[…]  
W0207 22:03:23.049794 main.cpp:1224] Using a custom database from plugins  
W0207 22:03:23.049820 OrthancInitialization.cpp:376] Storage directory: “/data/OrthancStorage”  
I0207 22:03:23.058878 PluginsManager.cpp:172] Installing the CreateInstance extension  
E0207 22:03:23.065256 PluginsManager.cpp:164] PostgreSQL error: ERROR: syntax error at or near “ASSERT”  
LINE 32: ASSERT studyKey IS NULL;  
^

W0207 22:03:23.065748 PluginsManager.cpp:168] PostgreSQL: An active PostgreSQL transaction was dismissed  
I0207 22:03:23.065847 PluginsManager.cpp:172] Closing connection to PostgreSQL  
[…]

Any ideas?

Best,

Philippe

---

<div class="post-metadata">

### Author: ![jodogne](https://discourse.orthanc-server.org/user_avatar/discourse.orthanc-server.org/jodogne/32/1511_2.png) [@jodogne](https://discourse.orthanc-server.org/u/jodogne)
#### Post date: [February 8, 2019, 8:10am UTC](https://discourse.orthanc-server.org/t/orthanc-upgrade-problem-1-3-0-to-1-5-3/1317/2 "2019-02-08T08:10:54Z")

</div>

Hello,

This issue has been discussed previously on the forum:  
[https://groups.google.com/d/msg/orthanc-users/BXfmwU786B0/J0\_nPoZzFwAJ](https://groups.google.com/d/msg/orthanc-users/BXfmwU786B0/J0_nPoZzFwAJ)

This is due to the fact that your PostgreSQL server is too old to support the “RAISE” SQL instruction.

This is fixed in the mainline, and will be part of forthcoming release 3.1 of the PostgreSQL plugins. You could upgrade your PostgreSQL server as well.

Sébastien-

---

<div class="post-metadata">

### Author: ![Philippe\_Despres](https://discourse.orthanc-server.org/letter_avatar_proxy/v4/letter/p/b5a626/32.png) [@Philippe\_Despres](https://discourse.orthanc-server.org/u/Philippe_Despres)
#### Post date: [February 14, 2019, 2:18am UTC](https://discourse.orthanc-server.org/t/orthanc-upgrade-problem-1-3-0-to-1-5-3/1317/3 "2019-02-14T02:18:41Z")

</div>

Thanks. I used version 3.1 instead of updating my Postgresql install.
