Orthanc Transfers Accelerator error

Hello,

when I try to upload 200 Mb of images with OrthancPeer from a server in a intranet to a server exposed to the internet it runs succesfully

if i try the same study using Transfer Accelerator I have this error (see in attach)

Any idea about ?

Max

Cattura.JPG

Yes I got this error time to time too.
But unfortunately I
Forget to retrieve the logs.

Can you look if you have error message in your log ?
I will look on my side too.

Now I remember, I solved this kind of bugs by increasing the httptimout, it had 10 in the default orthanc.json and I put it to 120 like suggested in the transfert plugin documentation.

Can you try if 120 solve your case.

I just figured that this bug that I saw in my orthanc was also an orthanc with httptimout settings at 10.

I tried many so different ways to make Accelerator plugin work in stable mode but there is always one or two errors in studies with too many images (CT/MR). I have posted similar issue in the form.

For me peer-to-peer works much better via OnStoredInstance().

I would love to use Accelerator if I know what could be the issue.

Best regards,

As long as you don’t provide us with a way to independently and systematically reproduce your issue (very importantly, including sample DICOM data), we can’t provide any further help.

Maybe it’s because your problematic studies are so large that the initial HTTP request that gathers information about all its DICOM files hits the timeout. As suggested by Salim, increase the timeout to several minutes, and try with a SSD drive.

As always, check out your logs in “–verbose” mode:
http://book.orthanc-server.com/faq/log.html

Sorry Sebastien,

following the book at : http://book.orthanc-server.com/faq/log.html

at the point : 5. Restart the Orthanc service. → The service start and then stop

Max

Orthanc.log (14.3 KB)

Maybe because the service runs with PostgreSQL plugin ?

Max

I’ve just made some clarifications:
http://book.orthanc-server.com/faq/log.html#under-windows

Just send the “C:\Temp\Orthanc.log” that is generated at step 4. Step 5 simply consists in going back to normal operations.

Many thanks Sébastien

Max

Biotron spa con iOS