OrthanC server and minPACS

Dear OrthanC Gurus,

I have completed setup OrthanC PACS and now would like to receive images import from the miniPACS.

Here is my setup:

OrthanC Server:

Internal IP: 172.16.2.10

// The DICOM Application Entity Title
“DicomAet” : “ORTHANC”,

// Check whether the called AET corresponds during a DICOM request
“DicomCheckCalledAet” : false,

// The DICOM port
“DicomPort” : 104,

Internal IP: 192.168.1.1 (Link 172.16.x.x from router and able to ping to and from)

MiniPACS has following info:

PACName: CT
AET: MXV
IP: 192.168.1.1
Port: 104

Above info have been added to Configuration.json on OrthanC Server.

“DicomModalities” : {

“CT” : [ “MXV”, “192.168.1.1”,104 ]

Testing scenario:

  1. from Explorer/Browser, I am able to drag and drop DCOM images to OrhtanC server
  2. From DCOM Query/retrieve, I selected Server ‘CT’ and then clicked on ‘Test Echo’, it gives errors: Error: The C-Echo has failed!

Not sure what it is or where it is that I have configured wrongly. Please help me out.
Many thanks.

Regards,
Anousak

Hello,

OrthanC Server:

Internal IP: 172.16.2.10

[snip]

Internal IP: 192.168.1.1 (Link 172.16.x.x from router and able to
ping to and from)

Just to make sure, you've listed two "Internal" addresses in your
"Orthanc Server" section. I'll just assume Orthanc is assigned 172* and
the MiniPACS 192*.

MiniPACS has following info:

PACName: CT
AET: MXV
IP: 192.168.1.1
Port: 104

"DicomModalities" : {
"CT" : [ "MXV", "192.168.1.1",104 ]

This looks good.

2. From DCOM Query/retrieve, I selected Server 'CT' and then clicked
on 'Test Echo', it gives errors: Error: The C-Echo has failed!

Can you check and possibly send the relevant Orthanc logs? Also
consider running it with --verbose or --trace if necessary.

When you mention a ping test, I assume you've pinged 192.168.1.1 from
the Orthanc host. If this indeed works and the logs don't reveal
anything useful I recommend trying to connect to the 104 TCP port using
e.g. telnet (command: telnet 192.168.1.1 104) to verify that no
firewall is preventing the connection. Finally, I would capture network
traffic on both hosts (e.g. with tcpdump/windump) and look at it with a
tool like Wireshark. Feel free to post some captures here if you need
help.

Long shot: You know your network of course, but just in case I'll note
that 192.168.1.1 is often used by default by various gateway devices.
It might be worth double-checking that there is no address conflict on
the network.

I suggest you do all of this in order of simplicity until you find the
root cause of the issue.

Good luck,

Many thanks for prompt reply. I will do some further checking and be back to forum soon.

Regards,
Anousak

H Thibualt and all,

By the way I I did some checking and restarting Ortahnc, and did Test Echo via browser, here is what I got through verbose command line.

W0406 03:58:01.582131 main.cpp:824] DICOM server listening with AET ORTHANC on port: 4242
W0406 03:58:01.582172 MongooseServer.cpp:888] This version of OpenSSL is vulnerable to the Heartbleed exploit
W0406 03:58:01.582193 MongooseServer.cpp:1028] HTTP compression is enabled
W0406 03:58:01.591895 main.cpp:759] HTTP server listening on port: 8042
W0406 03:58:01.591941 main.cpp:646] Orthanc has started
E0406 03:58:21.768496 DicomUserConnection.cpp:167] DicomUserConnection: Peer aborted Association (or never connected)
E0406 04:06:43.167795 DicomUserConnection.cpp:167] DicomUserConnection: Peer aborted Association (or never connected)

Peer aborted Association (or never connected)”

I am not familiar and can’t find related error in the forum, but it is something about about Firewall?

This scenario between two networks as said: 172.16.x.x and 192.168.x.x is passing through a firewall. I am wondering which port for DICOM protocol I need to enable in the firewall, if so.

Many thanks,
Anousak

DICOM operations between two hosts usually require the establishment of
TCP connections in both directions (technically not always necessary,
but the semantics of a C-MOVE often make it so).

So, in your case (considering you've configured both servers to listen
on port 104), you need to allow:

- 192.168.1.1 -> 172.16.2.10: TCP/104
- 172.16.2.10 -> 192.168.1.1: TCP/104

I encourage you to capture network traces to confirm the source the
problem if this doesn't work.

Review firewall rules for allowed port(s).