Orthanc explorer stopped working

I had explorer up and running fine one day, and the next day I can't get the explorer to work and I didn't change anything. It is returning a HTTP 400 error the request hostname is invalid.

Everything seems to be set up correctly. The ultrasounds can ping the ip address of the orthanc server, the ip address of the ultrasounds are static,

I just installed the new update and still can't get it to connect.

Does anyone know how I can fix this?

orthanc.json (12.8 KB)

Hi Catherine,

Could you return the full log of orthanc (with --verbose option, see http://book.orthanc-server.com/faq/log.html) ?
At first sight, this error seems unrelated to Orthanc. Could you provide detail about your setup (dns, proxy if any, …) ? Is it working on localhost (http://127.0.0.1:8042/) ?

Kind Regards,
Thibault

It is not working on the local host either. we have a dns setup and windows operating system. Attached is the log and it looks like something wrong is going on, I just don't know how to fix it.

orthanc.json (12.8 KB)

Hi Catherine,

I think you sent the Orthanc configuration file instead of the log.

`

oops. Here is the correct file.

Orthanc.log (3.01 KB)

Hi catherine,

My colleague reported me the exact same problem than yours.
It happened today while his Orthanc was working smoothly from months.

He is in windows 10 and he told me that it may be linked to a Windows update.

Are you also in windows 10 and did you made an update recently ?

Salim

In fact I'm wrong I misread the error, it is not the same one

The relevant error seems to be “Uncaught exception, stopping now: [The TCP port of the HTTP server is privileged or already in use] (code 2003)”

This means some other program is using the http port, 8042 according to your configuration. This may be another instance of Orthanc.

Chico Venancio

Thanks Chico! I had read this could happen, but I couldn't figure out how to actually tell if two things were running on the same port. And if there was how to stop one of them. I've got my IT guy coming tomorrow, so hopefully he can figure it out. Thanks again!

Hello,

Thanks Chico! I had read this could happen, but I couldn't figure out
how to actually tell if two things were running on the same port. And
if there was how to stop one of them.

On Windows: Use `netstat -ano -p tcp`[1] (e.g. in "Command Prompt"). In
the returned list you may lookup the entry for *:8042 and look for the
number in the PID column. You can then open the task manager and lookup
the PID to figure out what process is listening there and end it if
necessary.

[1] https://docs.microsoft.com/en-us/windows-server/administration/wind
ows-commands/netstat

That port is used by the NT Kernal , PID 4 on my Windows 10 Pro installation. I suspect it's really IIS. Dumb newbie Q: Do I need to stand up IIS or does the Orthanc installer configure its own web service without needing a local web server running? Restated, should I NOT have IIS running? I stopped that serer in IIS and same problem.

IIS is not needed, though I suppose it can be used like Apache or Nginx to redirect port 8042 to 80 and facilitate use from other computers in the network and possibly handle permissions and security. I don’t have much experience with IIS so I can’t help you there.

Unless you messe around a lot with the default configurations, though, IIS should not interfere with Orthanc at all. As far as I know it does not use the 8042 port by default.

Using “netstat -ano -p tcp” or resource monitor’s network tab will allow you to see what is the program using the needed port.

IIS is not needed, though I suppose it can be used like Apache or
Nginx to redirect port 8042 to 80 and facilitate use from other
computers in the network and possibly handle permissions and
security. I don't have much experience with IIS so I can't help you
there.

FWIW, if all that is required is to expose port 80 then one can use
Orthanc's HttpPort setting. Reverse proxying is still definitely useful
for things like TLS termination, access control, logging, load
balancing and to share the same port with other virtual servers, among
others.

Unless you messe around a lot with the default configurations,
though, IIS should not interfere with Orthanc at all. As far as I
know it does not use the 8042 port by default.

I am not familiar with IIS/http.sys at all but I'm fairly sure any
application can bind a port with it. One would need to consult
http.sys-specific documentation on how to retrieve a list of the
relevant processes.

IIS is not needed, though I suppose it can be used like Apache or Nginx to redirect port 8042 to 80 and facilitate use from other computers in the network and possibly handle permissions and security. I don’t have much experience with IIS so I can’t help you there.

Regarding this particular point, the Orthanc Book contains an example to setup a reverse proxy with IIS:
http://book.orthanc-server.com/faq/iis.html

HTH,
Sébastien-