orthanc docker image login not possible

i have a problem with the docker image provided on github
maybe anyone can give me a hint, any help would be appreciated?

i started the docker image, but i cannot login to the webserver (it
alway claims that the authentication failed

but i provided the standard user/password combo orthanc/orthanc

it even does not allow login if i disable the authentication within the
orthanc config file

here´s how i start the image:

docker run -p 4242:4242 -p 8042:8042 --rm
-v /opt/ORTHANC/orthanc-db/:/var/lib/orthanc/db/ -v
/opt/ORTHANC/orthanc.json:/etc/orthanc/orthanc.json:ro
jodogne/orthanc-plugins --trace

my orthanc config is in the attachment

orthanc.json (11.2 KB)

Hello,

I have tried your command, and it works fine on my computer.

Please be sure that you use the latest Docker image by issuing:

sudo docker pull jodogne/orthanc-plugins

HTH,
Sébastien-

i´ve tried 3 different computer everytime the same (2xlinux 1x macosx)

the authentication box requests the username & password --> i enter them --> same authbox apears again.

i also tried this one: docker run -p 4242:4242 -p 8042:8042 --rm jodogne/orthanc-plugins --trace

see screenshot

Bildschirmfoto 2016-06-29 um 16.10.16.png

Remove the trailing “–trace” and it should run fine.

If you want to have higher verbosity, you need to provide the “/etc/orthanc” path as well:

docker run -p 4242:4242 -p 8042:8042 --rm jodogne/orthanc-plugins /etc/orthanc --trace

Regards,

Sébastien-

PS: There was indeed an error in the README, this is now fixed:
https://github.com/jodogne/OrthancDocker/commit/bf56868c8804cafe462b71684d7bb21fe41baff5#diff-04c6e90faac2675aa89e2176d2eec7d8