new server 19.3.2 installation issues

A Veterinary center, here in our city asked us for a new DICOM server. They replaced their old radiological system, which does not come with this function, so to share the radiological images between the various vets.

i tried and install a new Orthanc Server instance, version 19.3.2 for windows.

The Windows box is an Intel NUC i5, 8gb, 1TB Raid 1 SSD, intel Gigabit Ethernet, Windows 10 Pro, 1809 (October 2018 release). No third party Firewall, just Window’s. Latest drivers loaded.

Installation went flawlessly. I opened the ports in Windows Firewall, 4242, 8042 and also 11112 (just in case i change server port).

IP of the server is 192.168.70.81 (reserved DHCP), i include the orthanc.json config.

Service runs fine, we loaded some dicom samples images, locally and remotely (via username and password correctly set) i can access the Orthanc Explorer via Web page, browse the studies, search them, use the Osimis web viewer. No issues.

Here comes the problem; we have radiant viewer licenses, app latest version (4.6.9 64bit). We setup the PACS server info as the image included, and we get green at test connection.

But if i search ( no search filters set), most of the times i get no results. Both locally but also on a remote machine.

Sometimes, less than 5 time on 10, i can see the study list (3 right now) but if download one of them, connection is slow (3 or 6kb/s) the drops.no study is displayed. If it works locally, it does not on another pc, and viceversa.

I have no clue, hope you can help. Let me know if you need oher info.

Thanks again.

Fracesco

radiant.jpg

orthanc.json (20.3 KB)

Although I’m getting to grips with Orthanc myself, I believe the only thing that you’ll need to do is to add your workstations settings into Orthanc’s configuration, it appears that your current config is all commented out

"DicomModalities" : {
    "RadiantWorkstation1" : ["WORKSTATION_AET", "WORKSTATION_IP_ADDRESS", WORKSTATION_DICOM_PORT]
}

Where

  • RadiantWorkstation1 : is just a label, that will be listed in the Query/Retrieve section of Orthanc
  • WORKSTATION_AET : the AET of your Radiant workstation. Although typically is used more for sending images to your workstation, there are also config options that check the AET of the calling entity before Orthanc responds
  • WORKSTATION_IP_ADDRESS : the IP address of your Radiant workstation
  • WORKSTATION_DICOM_PORT : again, the port that your Radiant workstation would accept images on.

When working with the configuration files, ensure that they are correctly formatted JSON (you can paste your config into https://jsonlint.com/ to check that it’s valid)

HTH,

Dave

I use Radiant with Orthanc. In 2 Veterinary clinics… You can query and see the studies… that is good, but you need to have each Radiant station’s info entered as an AET in the orthanc.json file
Each instance of Radiant must have a unique AET name and a unique listening port. If you repeat these, then when you fire up one instance over another, it will knock the first one out.

json example follow the syntax of the clearcanvas example that is commented out.

  • A fourth parameter is available to enable patches for
  • specific PACS manufacturers. The allowed values are currently:
    • “Generic” (default value),
    • “GenericNoWildcardInDates” (to replace “*” by “” in date fields
  • in outgoing C-Find requests originating from Orthanc),
    • “GenericNoUniversalWildcard” (to replace “*” by “” in all fields
  • in outgoing C-Find SCU requests originating from Orthanc),
    • “StoreScp” (storescp tool from DCMTK),
    • “ClearCanvas”,
    • “Dcm4Chee”,
    • “Vitrea”,
    • “GE” (Enterprise Archive, MRI consoles and Advantage Workstation
  • from GE Healthcare).

So to clarify… on the top line of your Radiant config… it would say for instance 11111 as the listening port and RADIANT1 as the AET

That top line defines the AET of the local Radiant copy. The Middle line… that you check the connectivity on is the AET and port of the Orthanc pacs server.

thanks Dave and John for you infos. i was already focusing on that parameters, but i was stuck assigning the same port.

fortunately the unit has not been delivered to the customer so i have time to set it up correctly
next week i’ll be in my lab, and i’ll do some more testing but i guess i will sort iy out with your precious hints.

ill post updates next week.

francesco

John,

“station1” : [“RADIANT1”, “192.168.1.25”, 11111],
“station2” : [“RADIANT2”, “192.168.1.26”, 11112]

The ports listed for each “station” can actually be the same, I believe, as they refer to the port on that station that would receive images from Orthanc. Sebastien can confirm this, but when a C-STORE is made from Orthanc to a station, Orthanc would look up the receiving party’s AET and references that party’s IP address, and then the port is used in setting up the comms. This is opposed to requiring unique values for both the station’s AET and station’s port to Orthanc. The AET definitely needs to be unique as that’s the identifier that Orthanc uses to specify a particular host.

As stated, Sebastien can certainly confirm this, but my gut tells me that Orthanc uses DCMTK at the core of it’s DICOM server and (at least) earlier versions of DCMTK’s storescp utility works in this manner. My experience of DICOM over the years has lead me to understand that many OEMs take varying views on this very topic!

Dave

The ports listed for each “station” can actually be the same, I believe, as they refer to the port on that station that would receive images from Orthanc. Sebastien can confirm this, but when a C-STORE is made from Orthanc to a station, Orthanc would look up the receiving party’s AET and references that party’s IP address, and then the port is used in setting up the comms.

Indeed, several entries in the “DicomModalities” option can share the same IP and TCP port.

This is opposed to requiring unique values for both the station’s AET and station’s port to Orthanc. The AET definitely needs to be unique as that’s the identifier that Orthanc uses to specify a particular host.

Several entries in the “DicomModalities” can share the same AET and TCP port. Even if this does not make much sense in general, this is allowed.

The only uniqueness constraint is on the symbolic name of the modalities (i.e. the keys of the “DicomModalities” associative array).

As stated, Sebastien can certainly confirm this, but my gut tells me that Orthanc uses DCMTK at the core of it’s DICOM server and (at least) earlier versions of DCMTK’s storescp utility works in this manner. My experience of DICOM over the years has lead me to understand that many OEMs take varying views on this very topic!

Indeed, Orthanc is built on the top of DCMTK as far as DICOM is concerned.

Sébastien-

sorry guys, but still no go.

my config:

one server (that works also as client with radiant) and a client with only radiant

SERVER: name=server-app: ip 192.168.70.79 windows firewall port open: 4242, 8042, 11112, 11111
CLIENT: name=tecnico01: ip 192.168.70.95 windows firewall port open 11112,

when defining server, i get green check, when quering nothing appears

i include my config, if anyone can give it a doublecheck.

Orthanc Explorer works great. radiant no why. what am i doing wrong?

thanks.

Francesco

orthanc.json (20.3 KB)

What is your Client AE title? ORTHANC2?

Remove “SERVER-APP” : [ “ORTHANC1”, “192.168.70.79”, 11111 ],s
from the config. If SERVER-APP is the Orthanc Server.

You are almost there. Assuming Radiant has your pacs location and orthanc server in the pacs locations section correctly and you have the

green checkmark when tested, and you can browse for studies…

In your json configuration you are needing to give the name of the “allowed” client AET’s (ie the AET name and ip address of the Radiant station)

so for example if the address of the tecnico0 machine really is 192.168.70.95 then I would set it up for clarity in the json as

“RADIANT1” : [“RADIANT1”, “192.168.70.95”, 11112 ]

then in Radiant on your top line on the pacs configuration window would be

listener port 11112 My AE title RADIANT1

sets up the Technico01 machine’s copy of radiant to match the line in your json that show’s it is allowed

to download radiographs.

Orthanc will allow browsing promiscuously, but only seems in it’s default config to allow download of images only to

explicitly named AET’s

I think that your AET name Caps are significant so technico01 is not the same as TECNICO01

RADIANT1 may not be equivalent to radiant1

It maybe a late reply but have you tried opening radiant viewer in administrator mode ("run as administrator") that has worked for me.