MPEG4 Orthanc not working.

Dear Team

Hoping you are good, im trying to send a mp4 file to ORTHANC using RZDCX API to convert and send(store) the video in dicom format. These are the results:

  • Sending the dicom video file with transfer syntax MPEG2 Main Profile @ Main Level : “1.2.840.10008.1.2.4.100” AND MPEG2 Main Profile @ High Level : “1.2.840.10008.1.2.4.101” allows to store the video, however, cannot be played in the osimis web viewer.(Screenshot attached)

  • Sending the dicom video file with transfer syntax MPEG-4 AVC/H.264 High Profile / Level 4.1 : “1.2.840.10008.1.2.4.102” throws an error saying “Transfer Syntaxes Not Supported”.

  • Uploading the dicom video file generated in the previous step to ORTHANC manually, works fine and the video is able to be reproduced.

Saying this, why MPEG4 is not supported as a valid transfer syntax when trying to store it? Is there any way to allow this transfer syntax in ORTHANC?

Also, do you have any example to generate the mp4 and store it with FODICOM?

I really appreciate your support on this. Thanks!

no_video.JPG

Hi Carlos,

MPEG-2 are actually not supported by standard browsers (https://developer.mozilla.org/en-US/docs/Web/Media/Formats/Video_codecs#MPEG-2)

For the MPEG-4 Transfer syntax issue, could you share a (small) file such that we can reproduce it ?

Hello Alain

Thanks for your reply. Im attaching the video im using for testing purposes. As i stated before, this video has been converted using the transfer syntax “1.2.840.10008.1.2.4.100” and “props.VideoFormat = VIDEO_FORMAT.MPEG2_AT_MAIN_LEVEL;
The dicom file arrives to ORTHANC, however cannot be played as per your statement that modern browsers cannot played this type of format.

image.png

If i use the transfer syntax : “1.2.840.10008.1.2.4.102” and “props.VideoFormat = VIDEO_FORMAT.MPEG4;” the store scp command throws this error:

image.png

Therefore, the dicom file will not be stored in orthanc.

Thanks for your support on this matter.

Regards

rzdcx.log (4.21 KB)

Hi Carlos,

At this point, I can just confirm that I’ve been able to reproduce your issue with the DICOM file from http://viewer-basic.osimis.io/instances/e465dd27-83c96343-96848735-7035a133-1facf1a0/file and the following command:

storescu -v localhost 4242 6af9b59f-2d76-4cb6-9dc6-5cdafa436e1d.dcm

even while setting this configuration:

“UnknownSopClassAccepted”: true,

I’ll continue to investigate but I’m not really familiar with that part of the code.

image.png

image.png

Thank you Alain

Right now im using RZDCX which allows me to build and send dicom commands very quick, however im trying to use FO-DICOM in order to perform the same action(convert a video and send it to orthanc), however it always misses the transfer syntax UID.
Thanks again and waiting then for further notice about this.

Kind regards.

image.png

image.png

Hello,

Support for the MPEG4 transfer syntaxes is not enabled in Orthanc <= 1.5.8.

I have just enabled this support in the mainline of Orthanc, through the following changeset that will be part of forthcoming 1.6.0 release:
https://bitbucket.org/sjodogne/orthanc/commits/8aab20dde416d60ee94b97991cd91b2165cf3792

For reference, here is the command-line to send the MPEG4-encoded DICOM file provided by Alain using DCMTK’s storescu:

$ storescu -xf /tmp/storescu.cfg Default localhost 4242 /tmp/6af9b59f-2d76-4cb6-9dc6-5cdafa436e1d.dcm

Where “storescu.cfg” is derived as follows from the default configuration of DCMTK 3.6.2 (I’m using Ubuntu 18.04 LTS):

$ diff /etc/dcmtk/storescu.cfg /tmp/storescu.cfg
198c198
< PresentationContext128 = VideoPhotographicImageStorage\MPEG2

Thank you Sebastien!