Modification of existing resources is changing other tags

Hey all,

Just wondering if anyone ran into this issue after upgrading to Orthanc 1.3.2.

We had an autorouting Lua script (attached) that modified a single tag. Previously in Orthanc 1.2.0 and earlier, this script worked perfectly (for almost 2 years).

Now we noticed that the FrameOfReference [1] is getting modified as well as the ReferencedImageSequence → ReferencedSOPInstanceUID [2].

The strange thing is that [1] and [2] are getting a new value for EACH instance in the series.

Also upon further testing, when anonymizing instead of modifying the study, the behavior is correct ([1] & [2] are modified but static values).

I think this may have something to do with the following changeset: https://bitbucket.org/sjodogne/orthanc/commits/51b91ead6c386dc715af6299ebe7a09857f7f60e

Thank you,

Adit

AutoroutingModification.lua (1.29 KB)

Hi Aditya,

Thanks for reporting the issue. Indeed, this is a regression that has been introduced by the changeset you mentioned.
I have created an issue in our Tracker: https://bitbucket.org/sjodogne/orthanc/issues/94/a-simple-instance-modification-shall-not

We’ll probably fix it for the next release.

Best regards,

Hi Alain,

Thanks for confirming. Will reverting to 1.3.1 resolve the issues for the short term? Any worry about database schema changes?

Thanks,

Aditya

no, downgrading to 1.3.1 is safe, just replace the Orthanc executables (or docker containers)

Hello,

For reference, this issue should be solved as of Orthanc 1.4.1.

Don’t hesitate to give a try upgrading Orthanc.

Regards,
Sébastien-