Modality filters

Dear Community,

I have a little problem with my Orthanc server. It stores DICOM images from all of our modalities. When I try to query some MR exams on any dicom workstation (Radiant, Horos or whatever) from my Orthanc server - I only see a few exams.
Without filter (MR modality) I can see 10+ MR studies, but after checking the MR filter, only 2.
Can you help me with this issue?
Screenshots and logs are attached.

Screenshot2.png

Screenshot4.png

Screenshot1.png

Screenshot3.png

Hello,

Have you tried to set the value of the configuration option “LimitFindResults” to 0, or to a value larger than 100?

https://hg.orthanc-server.com/orthanc/file/Orthanc-1.9.7/OrthancServer/Resources/Configuration.json#l528

I indeed see in your “Screenshot2.png” that you hit the limit of 100 in the “fast DB filtering” step, maybe because your studies contain a large number of series with “MR” modality.

Sébastien-

Hello,

Yep, thank you!
Setting LimitFindResults to 0 solved my problem. Didn’t expect that, because without a filter, all MR studies are shown.

пятница, 10 сентября 2021 г. в 08:44:52 UTC+3, s.jo...@gmail.com: