Issue: Send DICOMs to remote modality by REST

I would like to migrate all files from Orthanc to Conquest. I’ve tried a few options how to send all the DICOMs effectively:

  1. dcmsend (dcmtk) files one-by-one directly from database directory
  2. script modified to send instances to remote modality (conquest)
  3. Web server api manually for 2 subjects.

Zrzut ekranu 2019-01-10 o 15.08.38.png

Only the last option worked correctly. For 1&2 files seems to: have weird subject id, Conquest cannot generate preview and print dicom header of the files, I can’t download the files from Conquest (size 22kB). So, luckily manual option works fine but I can’t do this automatically.
Please let me know if there is any option to fix it. I use latest docker version with postgres (database only) plugin.
Bartosz Kossowski

Excuse me for previous message. It looks like conquest is not able to process files which have “-“ in patient id :slight_smile:

Nevertheless it should outperforms Orthanc in response for queries. I have a database of 10e7+ files (6000 subjects). I have to wait minutes to find subjects by fields not indexed in posteres schema.

Zrzut ekranu 2019-01-10 o 15.08.38.png

Is this delay querying Conquest? If so, I would test with a different client against Conquest to verify where the issue exactly is. I myself have not found Conquest to be too responsive.


Are you sure to be using the latest version Orthanc (1.5.1)?

If so, have you looked at the “StorageAccessOnFind” configuration option of Orthanc, and have you set “LimitFindResults” and “LimitFindInstances” to e.g. “100”?


Yes, I’ve checked version and added recommended parameters. Have You observe any drop of performance when using docker version (jodogne/orthanc-plugins)? My query regarding all subjects starting with some 3 letters code is analyzed for 1-2 minutes resulting in eg. 30 subjects. I find it very slow comparing to our vendor PACS.

W dniu czwartek, 10 stycznia 2019 16:47:31 UTC+1 użytkownik Sébastien Jodogne napisał:


This is typically the known performance issue on C-FIND that will be solved by combining Orthanc 1.5.2 (released yesterday) with PostgreSQL plugin 3.0 (to be released in the next few hours/days).

The release of PostgreSQL 3.0 will be soon announced in the following thread:

Please try again after upgrading to this release once available.


I’ve just updated the docker image. Trigram was successfully created for database but I do not observe any significant speed up. My simple query is still processed 1-2 minutes. Is there anything more I can do? Are there any new options in config file?

W dniu sobota, 19 stycznia 2019 11:44:03 UTC+1 użytkownik Sébastien Jodogne napisał:

I have just added a new FAQ entry about this topic in the Orthanc Book: