Installation of authorization plugin on a Windows 64bits version

Hi,

I am unable to make the authorization plugin work.
My version of Orthanc is 20.4.1 for Windows 64 bits.

First in plugin section, I have the following:
“Plugins” : [ “…/Plugins/” ],

In Plugins directory the following plugins are installed (see attached file).

As per Orthanc book explanations, I have configured the following for authorization/authentication:

“Authorization” : {
“local-api” : “http://localhost:37080/rest/wadoServer/auth/
},

// Whether or not the password protection is enabled
“AuthenticationEnabled” : true,

// The list of the registered users. Because Orthanc uses HTTP
// Basic Authentication, the passwords are stored as plain text.
“RegisteredUsers” : {
“pierre” : “xxxxxx”
},

Of course I have an HTTP server running on port 37080 that serves the expected response.

When doing a WADO request, the HTTP response has 401 status:
HttpResponseProxy{HTTP/1.1 401 Unauthorized [Connection: close, WWW-Authenticate: Basic realm=“Orthanc Secure Area”, Content-Length: 0] [Content-Length: 0,Chunked: false]}

(Please note I don’t get a 403 as expected)

I tried to track if Orthanc was calling the callback defined (“http://localhost:37080/rest/wadoServer/auth/”) but it seems it does not happen.

My questions are:

Thank you very much for your help

Pierre

Orthanc plugins.png

Hi Pierre,

I’ve recently added the Authorization plugin in the Orthanc Windows Installers (20.5.0). They were indeed missing. Sorry for that. The new installers are available on Osimis website: https://www.osimis.io/en/download.html

I’m not sure about the mix of basic auth + auth plugin together. Orthanc might try to check both and it might be hard to imagine the output. The auth-plugin should mainly be used if you have another app in front of Orthanc and that web-app includes some auth-header in the requests to Orthanc.

Best regards,

Alain.

Dear Alain,

thank you so much! I confirm that it works!!!

In details, to share my experience:

  • authorization request is triggered on wado requests
  • it does NOT work with authentication enabled as you suspected

Thanks again for the prompt answer, much appreciated

Best regards