Help a video tutorial of installing Google Cloud Platform plugin of Orthanc.

Dear everyone,

I am a newbie of Orthanc. I knew that Orthanc provided a Google Cloud Platfrom plugin that can remotely upload and download DICOM images from a local Orthanc Server.

I already read the guideline:
https://book.orthanc-server.com/plugins/google-cloud-platform.html

but still not successful deploying Google Cloud Platfrom plugin on my PC. My PC’s OS is window 7 installed Orthanc Server.

Could you please help me by providing a video tutorial, or a step-by-step about this issue.

Thanks in advance.

Thien Le

Hi,

If you’re running the latest Orthanc version, the google plugin will be enabled by default.

All you should have to do is create a new configuration file “google.json” in C:\Program Files\Orthanc Server\Configuration with a content like this one:

{
  "GoogleCloudPlatform" : {
    "Accounts": {
      "my-google" : {
        "Project" : "osimis-test",
        "Location" : "europe-west2",
        "Dataset" : "test",
        "DicomStore" : "dicom",
        "ServiceAccountFile" : "dicom-osimis.json"
      }
    }
  }
}

To fill the correct field in the json file, I encourage you to read this part of the Orthanc book: https://book.orthanc-server.com/plugins/google-cloud-platform.html?highlight=google#id6

HTH

Alain.

Dear Alain,

Thank you for your helping. I already created “google.json” file as your suggestion and placed it in the configuration folder of Orthanc. Now when I open the Orthanc web client, the name “my-google” appears in the list of DICOMweb server, but I cannot connect to my google cloud health, the issue is " error connecting to ''my-google" server"
Here is my google.json"

issue.png

Hi,

I just tried from a clean system and all I had to do beside configuring the google cloud plugin was configure “HttpsCACertificates” : “C:\Program Files\Orthanc Server\Configuration\cacert.pem” where cacert.pem was downloaded from https://curl.haxx.se/docs/caextract.html

At this point, it would be nice to collect some logs:

Note that to debug HTTPS communications, you have the possibility of setting the HttpVerbose configuration option of Orthanc to true. You should also run Orthanc in --verbose mode (check out this page).

Dear Alain,

Thanks you for your help.
I successfully installed the Google cloud plugin on my windows laptop.

Dear All,

I am also trying to deploy Google Cloud Platform plugin, I have followed all steps given in the same conversation.But i am unable to find out GCP at Orthanc server. I have attached screenshot as well.

Your guidance will greatly appreciated.

Thanks in advance!

dicomWebServer.PNG

Dear Neha Wankar,

Perhaps you forgot to implement the Dicomweb plugin. Google Cloud Platform requires Dicomweb plugin to run.
Remind that: Google Cloud Platform requires OrthanC version larger than 1.5.4 and Dicomweb version at least 1.0.

If still not working, you can attach pics and your configurations .json files of Google Cloud Platform and Dicomweb in order to solve the problem.
In my case, I can use Google Cloud Platform plugin in my Window PC.

Best regards,
Thien Le

Vào Th 2, 10 thg 2, 2020 vào lúc 14:51 Neha Wankar <nehawankar174@gmail.com> đã viết:

Dear Thien Le,

Thank you so much for quick reply.

I am also working on Window PC having OrthanC version “1.5.8” and Dicomweb version “1.0”.
I have attached configurations .json files of Google Cloud Platform and Dicomweb also log file where is saying “Cannot generate Google Cloud Platform token for account: my-google”.

Please guide me if I missed anything.

Thanks,
Neha

dicomweb.json (692 Bytes)

google.json (293 Bytes)

orthanc.json (21 KB)

Orthanc.log.20200210-161424.16332.txt (6.14 KB)

Dear Neha Wankar,

Your dicomweb.json is okay. However, in the orthanc.json, you should change “RemoteAccessAllowed”: false → true.
The location of the file “service_key.json” in “ServiceAccountFile”: “./service_key.json” maybe wrong with “./”.
For my case, I placed the “service_key.json” in the configuration folder and wrote “ServiceAccountFile” : “service_key.json”.

Hope this helps you.

Best regards,
Thien Le

Vào Th 2, 10 thg 2, 2020 vào lúc 17:02 Neha Wankar <nehawankar174@gmail.com> đã viết:

Hey Thien Le,

Thank you for your valuable time.
I have made changes according to your suggestions, now when I restart Orthanc server, it asks for Username and Password. Where this details are saved?

Thanks,
Neha

userNamePassword.PNG

Hi, Neha Wankar,

You can try this in the orthanc.json:

 "RegisteredUsers" : {
    // "alice" : "alicePassword"
  },

User: alice
Password: alicePassword
Of course you can change both.

Best regards,
Thien Le

Vào Th 2, 10 thg 2, 2020 vào lúc 20:19 Neha Wankar <nehawankar174@gmail.com> đã viết:

Hi

Yes I have registered user from orthanc.json, now able to login but still facing same “No DICOMweb server is configured!”

Is there anything again that I missed?

Thanks,
Neha

Well, I think because of this. You have to delete: ““RemoteAccessAllowed” : true,” in your Dicomweb json file.

I hope this helps you can run.

Best regards,
Thien Le

issue.png

Vào Th 2, 10 thg 2, 2020 vào lúc 20:34 Neha Wankar <nehawankar174@gmail.com> đã viết:

Hi,

Deleted “RemoteAccessAllowed” : true," from Dicomweb json file. Still there is “No DICOMweb server is configured!” :frowning:

One more thing, in log file, there is error, “W0210 19:28:44.253430 PluginsManager.cpp:168] Cannot generate Google Cloud Platform token for account: my-google
Is it Google Cloud Platform configuration error but before that DICOMweb server should configured.

Thanks,
Neha

Yes, I think you are right. Did you see the plugin Dicomweb like mine? If not, you have to make the Dicomweb plugin enable first.

Best regards,
Thien Le
issue1.png

issue2.png

Yes, I can see DicomWeb pluggin.
If I click on plugins the I get list of all plugins and if click on “Open DicomWeb Client” then it redirect me to DicomWeb Client screen.
Attached are the screenshots.

Thanks,
Neha

dicomWebClient.PNG

orthancServer.PNG

plugins.PNG

Well, up to now I think you configured correctly. But I don’t know why too.

Do you restart your orthanc every time when you change the .json files?
Are you sure that you configured correctly the Google Heath API with your service account?

Sorry that I still cannot find the issue.

Best regards,
Thien Le

Vào Th 2, 10 thg 2, 2020 vào lúc 21:26 Neha Wankar <nehawankar174@gmail.com> đã viết:

Hi Neha Wankar,

Ah, I remember that last time I got the same issue as you. “No Dicomweb server is configured”.
I turn off my PC and forgot about Orthanc. After about some days, I revisited Orthanc and this time it ran Google Cloud Platform plugin.
I don’t know why :sweat_smile:

Vào Th 2, 10 thg 2, 2020 vào lúc 21:38 Thien Le <wavelets11@gmail.com> đã viết:

Yes, I have followed all steps which you have suggested. But still getting same error. So I am also unable to figure out.
Yah, I am restarting orthanc server everytime after any change and according to me I have included correct service account details as well.
Let me try again with new service account details.
Will let you know.

Thank you so much helping me to figure out the things.

Regards,
Neha

Hi Neha,

Have you followed step 2 of this section: https://book.orthanc-server.com/plugins/google-cloud-platform.html?highlight=google#common-parameters ?