GE Advanced Workstation 4.6

Greetings,

I’ve got a HP Z800 workstation running General Electric AW 4.6 (Advanced Workstation) OS (v20111012) that has some problems CMOVE-ing studies from Orthanc, the log is as follows:

W0425 12:17:24.374320 OrthancMoveRequestHandler.cpp:171] Move-SCU request received for AET “AW01”

E0425 12:17:26.374320 DicomUserConnection.cpp:159] DicomUserConnection: DIMSE Failed to send message

E0425 12:17:26.389945 MoveScp.cpp:183] IMoveRequestHandler Failed: Error in the network protocol

E0425 12:17:26.389945 CommandDispatcher.cpp:770] cannot handle command: 0xfff

Any way to debug this further and get to the cause of the error. CFIND works fine but as soon as they issue a CMOVE Orthanc goes into overdrive and bumps up to 60% cpu usage and after that becomes unresponsive and the only way to recover is kill the service (won’t stop when issued a Stop command) and restart it.

Hello,

Please make sure that you use the most recent version of Orthanc (1.0.0 or, better, mainline), and provide your full log file in “–trace” mode.

Regards,
Sébastien-

I am running 1.0.0.0, ran with --trace and got a HUGE log file (38MB) with about 600 000 log lines of the following:
Calling service 1389 from plugin C:/Orthanc/Plugins/OrthancPostgreSQL-2.0-Index.dll
Calling service 5001 from plugin C:/Orthanc/Plugins/OrthancPostgreSQL-2.0-Index.dll

After filtering out those lines the result is this:
https://gist.github.com/Ravenheart/203fde2cc6a9890ae073bbf7ab98751f

At line 159 is when the CMOVE starts and the same error 0xFFF occurs later on.

The log indicates that the problem occurs when Orthanc opens a DICOM SCU connection to the GE DICOM SCP server. You should now carry on more low-level tests, directly using DCMTK’s storescu tool.

First, download the problematic DICOM files from Orthanc. According to the log, this is the study whose StudyInstanceUID is 1.2.276.0.26.1.1.1.2.2016.149.31782.7560039. Choose one DICOM file from this study. I’ll refer to this DICOM instance as “test.dcm”.

Secondly, log on the computer where Orthanc is running, copy there the “test.dcm” file, and issue the following line after installing the DCMTK command-line tools [1]:

storescu -aet JOYSTICK_SCP -aec AW01 -d 10.0.5.67 4006 test.dcm

This will emulate the connection Orthanc is using. The “-d” flag will provide debug log from DCMTK. Please post the log here.

[1] http://dicom.offis.de/dcmtk.php.en

https://gist.github.com/Ravenheart/1f6d6e9081f0d38f6fa06b1abc50c34e

Do you want me to post it in the dcmtk forum as well?

The following indicates your file is encoded using JPEG:

W: DIMSE Warning: (JOYSTICK_SCP,AW01): sendMessage: unable to convert dataset from ‘JPEG Baseline’ transfer syntax to ‘Little Endian Explicit’

It is thus normal that storescu fails. Please try again by adding the “-xy” option to storescu:

storescu -xy -aet JOYSTICK_SCP -aec AW01 -d 10.0.5.67 4006 test.dcm

https://gist.github.com/Ravenheart/c96a978169f7341a08823a841963ae15

This log basically says that your GE modality does not accept receiving DICOM files encoded using JPEG.

Please get in touch with your commercial support by GE: Orthanc is definitely not the culprit here.

Regards,
Sébastien-

Thank you for the great response and support Sebastien! Forwarded the last log and conclusion to GE and they’ll be coming around to update their software.