dicomweb and gdcm plugin fail to build against 1.8.1

Hi Sebastien,
update fom orthanc 1.8.0 to 1.8.1 was smooth for the package itself, but now I see compilation errors that we did not have against 1.8.0:
dicomweb-Plugin:
Please see https://build.opensuse.org/package/live_build_log/home:DocB:Orthanc/orthanc-dicomweb/openSUSE_Leap_15.2/x86_64

(google groups does not allow to post relevant part of error message - too much text?)

gdcm-Plugin:
https://build.opensuse.org/package/live_build_log/home:DocB:Orthanc/orthanc-gdcm/openSUSE_Leap_15.2/x86_64
basically the same error message:
[ 104s] /home/abuild/rpmbuild/BUILD/OrthancGdcm-1.1/Plugin/Plugin.cpp:86:9: error: ‘INFO’ was not declared in this scope

[ 104s] LOG(INFO) << “Decoding one DICOM instance of " << formattedSize << " using GDCM”;

[ 104s] /home/abuild/rpmbuild/BUILD/OrthancGdcm-1.1/Plugin/Plugin.cpp:86:5: error: ‘LOG’ was not declared in this scope

Please have a look.
Thanks
Axel

Hello Axel,

Sorry for the inconvenience.

These issues are already fixed upstream, but the fixes are currently pending in the mainline of the plugins, waiting for their next release.

In the meantime, you can use the patches I have just committed in Debian:
https://salsa.debian.org/med-team/orthanc-dicomweb/-/blob/master/debian/patches/logging
https://salsa.debian.org/med-team/orthanc-gdcm/-/blob/master/debian/patches/logging

Kind Regards,
Sébastien-

Hey Sebastien,
thanks for the quick reaction! Will test and if you dont hear from me, everything works!
Cheers
Axel