configuration.json trouble

Hallo, I installed three times Ubuntu 16.04LTS + clean install of 1.1, read all the threads, one is silmilar to my problem, but I have no 8042 port user. There’s no way to make http://book.orthanc-server.com/users/configuration.html happen
I nanoed :slight_smile: the configuration.json
password not working neither when I change it, I changed remote access to true

amministratore@pacserv:~$ Orthanc ./Configuration.json
W1212 20:14:56.445509 main.cpp:1222] Orthanc version: 1.1.0
W1212 20:14:56.447318 OrthancInitialization.cpp:135] Reading the configuration from: “./Configuration.json”
W1212 20:14:56.464946 FromDcmtkBridge.cpp:140] Loading the external DICOM dictionary “/usr/share/libdcmtk8/dicom.dic”
W1212 20:14:56.480782 FromDcmtkBridge.cpp:140] Loading the external DICOM dictionary “/usr/share/libdcmtk8/private.dic”
W1212 20:14:56.492603 OrthancInitialization.cpp:502] Registering JPEG Lossless codecs
W1212 20:14:56.492670 OrthancInitialization.cpp:507] Registering JPEG codecs
W1212 20:14:56.506109 OrthancInitialization.cpp:993] SQLite index directory: “./OrthancStorage”
W1212 20:14:56.554229 OrthancInitialization.cpp:1063] Storage directory: “./OrthancStorage”
W1212 20:14:56.570683 ServerScheduler.cpp:134] The server scheduler has started
W1212 20:14:56.571239 LuaContext.cpp:103] Lua says: Lua toolbox installed
W1212 20:14:56.571345 HttpClient.cpp:658] No certificates are provided to validate peers, set “HttpsCACertificates” if you need to do HTTPS requests
W1212 20:14:56.571380 ServerContext.cpp:168] Disk compression is disabled
W1212 20:14:56.571397 ServerIndex.cpp:1372] No limit on the number of stored patients
W1212 20:14:56.571446 ServerIndex.cpp:1389] No limit on the size of the storage area
E1212 20:14:56.571913 DicomServer.cpp:304] cannot create network: TCP Initialization Error: Address already in use
E1212 20:14:57.572292 main.cpp:1247] Uncaught exception, stopping now: [The TCP port of the DICOM server is privileged or already in use] (code 2004)
W1212 20:14:57.572836 main.cpp:1280] Orthanc has stopped

it’s 21:00 and my wife keeps calling me…

please help me!

Hi Marco,

The Orthanc HTTP port is already in use (most likely).
If you haven’t changed your config file, Orthanc is using port 8042.

You may try thiscommand:
$ sudo netstat -puta | grep 8042
If you get something listed, it means that another process is using it (and the last part of the line is the name of the process that is using it):
tcp6 0 0 [::]:8042 [::]:* LISTEN 3405/docker-proxy

Orthanc is most likely the only process that uses the port 8042 so maybe you already have another instance of Orthanc running in the background (i.e because you’ve installed the official package and this package installs Orthanc as a service).

regards,

Alain

Hello,

As said by Alain:

you’ve installed the official package and this package installs Orthanc as a service

If you wish to stop the default Orthanc service that comes with Ubuntu, run:

sudo /etc/init.d/orthanc stop

You will then be able to manually start Orthanc.

Sébastien-