changes to orthanc.json on httpPort and user name and passwords don't work

hi,

it still run on port 8042

// HTTP port for the REST services and for the GUI
“HttpPort” : 8000,

Server Logs

W0225 17:31:46.636626 HttpClient.cpp:1045] HTTPS will use the CA certificates from this file: /Users/admin/Documents/sks/Orthanc/Build
W0225 17:31:46.670453 LuaContext.cpp:104] Lua says: Lua toolbox installed
W0225 17:31:46.671854 LuaContext.cpp:104] Lua says: Lua toolbox installed
W0225 17:31:46.673691 ServerContext.cpp:318] Disk compression is disabled
W0225 17:31:46.674534 ServerIndex.cpp:1613] No limit on the number of stored patients
W0225 17:31:46.674946 ServerIndex.cpp:1630] No limit on the size of the storage area
W0225 17:31:46.683385 ServerContext.cpp:168] Reloading the jobs from the last execution of Orthanc
W0225 17:31:46.686768 JobsEngine.cpp:283] The jobs engine has started with 2 threads
W0225 17:31:46.690427 main.cpp:1008] DICOM server listening with AET ORTHANC on port: 4242
W0225 17:31:46.691246 HttpServer.cpp:1276] HTTP compression is enabled
W0225 17:31:46.691310 main.cpp:912] Remote LUA script execution is disabled
W0225 17:31:46.696663 HttpServer.cpp:1183] HTTP server listening on port: 8042 (HTTPS encryption is disabled, remote access is not allowed)
W0225 17:31:46.696751 main.cpp:715] Orthanc has started

thank you

You only provided an excerpt of your logs.

You most probably aren’t providing your configuration file when starting Orthanc. Check out for the line “Reading the configuration from…” in your log files.
https://book.orthanc-server.com/users/configuration.html