Access orthanc from remote computer

Hi everyone :slight_smile:

I had installed orthanc (version 1.5.6) in my linux machine with debian distribution

PRETTY_NAME=“Debian GNU/Linux 10 (buster)”
NAME=“Debian GNU/Linux”
VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster
ID=debian
HOME_URL=“https://www.debian.org/
SUPPORT_URL=“https://www.debian.org/support
BUG_REPORT_URL=“https://bugs.debian.org/

I had created a Configuration "Orthanc --config=Configuration.json "and changed the variables:

“RemoteAccessAllowed”: true,

“AuthenticationEnabled”: true,
“RegisteredUsers”: {
“alice”: “alicePassword”
},

and restarted again the orthanc “Orthanc Configuration.json”

but when I try to access it remotely a pop up is shown asking for the credentials, I had introduced user: alice and password: alicePassword, but it is not working

also I saw that the last version is 1.8.0 but when I install the orthanc using

sudo apt-get update

sudo apt-get install orthanc
I got the version 1.5.6
Could you please let me know how I can install the lastest version?

Thank you for your help

Configuration.json (20.2 KB)

Hello,

The following page of the Orthanc Book describes how to use the Debian/Ubuntu packages:
https://book.orthanc-server.com/users/debian-packages.html

As explained on this page, if you install Orthanc using “sudo apt-get install orthanc”, the Orthanc service reads its configuration from “/etc/orthanc/orthanc.json”.

To gain remote access to your Orthanc server, you must edit “/etc/orthanc/orthanc.json”, set configuration option “RemoteAccessAllowed” to “true”, then restart the Orthanc service.

Username and password will both be “orthanc” by default. This is obviously a security risk, so edit “/etc/orthanc/credentials.json”, and make sure to read the following instructions:
https://book.orthanc-server.com/faq/security.html#securing-the-http-server

Sébastien-